8

Even if I put the following, it still only makes IPv4 connections to the outside world:

ORPort [::]:9001 IPv6Only
OutboundBindAddress [::]
Bridge [<an IPv6 of a tor node of mine>]:9001
ClientUseIPv6 1
ClientPreferIPv6ORPort 1

I'm using tor-0.2.4.17rc.

How can I fix this problem?

  • Hmm, "Bridge []:9001" doesn't look like a valid config option. Do you use bridges for your attempt or not? – weasel - Peter Palfrader Oct 2 '13 at 7:38
8

There's only about 70 relays with an IPv6 address. So you should probably connect over IPv6 about one time out of sixty. But that's only if you don't use entry guards (you do use entry guards by default).

There is currently no client configuration option for not using IPv4. Also, if there was one, using that would sadly fail at the moment (see https://trac.torproject.org/projects/tor/ticket/6027).

1

I know that IPv6 works when using bridges.

This is my minimal torrc:

UseBridges 1
Bridge [<some ipv6 address>]:443
Log info stdout

When started with this torrc, my Tor only has connections to my bridge over IPv6.

I don't know if using a Tor client without bridges actually works with just IPv6 yet. If I find out I'll update this answer accordingly.

  • I was wanting to have my roaming laptop connect to some other tor relays as bridges directly instead of to the global network since I can encrypt the traffic over OpenVPN and hide what I am doing and/or not make a house I visit be marked as a tor site just because I exited traffic that heads to tor nodes. Bottom line is: server = 'ORPort' and optionally 'BridgeRelay' client = 'UseBridegs 1' and must not have 'ORPort' nor 'BridgeRelay' enabled Perhaps someone can adjust the tor manual pages around UseBridges accordingly? – todd Oct 2 '13 at 21:14
  • @todd, I'm not exactly sure what you're asking. But if you think we could improve the manpage, please file a bug on bugs.torproject.org describing what you would like to change and why. (Patches give brownie points, but aren't required.) – weasel - Peter Palfrader Oct 2 '13 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.