0

The following issue is reproducible on multiple Whonix instances.

While I can access many onion sites from Whonix Tor browser, certain sites report "The connection has timed out". These same sites load without problem in stand-alone Tor instance on my host machine.

For example, testing with Dread onion site: http://g66ol3eb5ujdckzqqfmjsbpdjufmjd5nsgdipvxmsh7rckzlhywlzlqd.onion

I can access this site without any issues from stand alone Tor browser (Ubuntu). However when I try to access the same onion from Whonix Tor browser I consistently get "The connection has timed out". I tried multiple Whonix instances (Running various Whonix versions 17.1.1.5, 17.1.0.2, 16.0.5.3). I tried rebooting all including the host, getting new identity - nothing works. Mind you, I can access many other onion sites from said Whonix systems.

1 Answer 1

0

Whonix is still buggy and immature - use QubesOS! The issue you're mentioning is ubiquitous for a years, I remember spotting it in 2018 myself! The answer lays in the Whonix's tor instance's logs - set them to debugging level and check it. It's usually either a network integration issue or a timeout on the onion pipe - you can check the logs. The standalone installation works fine because it can utilize an open ORPort and many other things, so it's integration is a way greater than Whonix's one

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .