0

I'm encountering an issue with the Tor Browser on my Mac. Every time I try to connect, I receive the following error message:

SETCONF DisableNetwork=0 -> 553 Unable to set option: Failed to bind one of the listener ports.

I've checked my hosts file and it seems standard, with no specific entries that should affect the Tor Browser. Here's the content for reference:

127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost
... [other standard entries] ...

Additionally, here's the relevant content from my torrc file, with sensitive information omitted for security:

ClientOnionAuthDir /Users/[username]/Library/Application Support/TorBrowser-Data/Tor/onion-auth
DataDirectory /Users/[username]/Library/Application Support/TorBrowser-Data/Tor
GeoIPFile /Applications/Tor Browser.app/Contents/Resources/TorBrowser/Tor/geoip
GeoIPv6File /Applications/Tor Browser.app/Contents/Resources/TorBrowser/Tor/geoip6

I've tried the following steps without any success:

  1. Checking if the required ports are in use using lsof -i :9051 and lsof -i :9050.
  2. Ensuring Tor Browser is allowed through the firewall on Mac.
  3. Tried using Bridge with "Automatic" mode and selecting my country.
  4. Tried disabling Wi-Fi and re-installing the Tor browser.

I'm looking for guidance on what might be causing this issue and how to resolve it. Any suggestions or troubleshooting tips would be greatly appreciated.

Thanks in advance for your help!

enter image description here

1 Answer 1

0

This problem is a frequent one on Windows, so looks like on macOS too now. The system built-in service is "accidently" either blocks or occupies 9050 and 9051 ports - point them to 19050 and 19051. That's it!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .