The service is enabled and active, furthermore journalctl -exft Tor says it is bootstrapped 100%.

However running torsocks on and trying to ping hackage.haskell.org will return nothing, ditto for cargo and other rust related servers; indictating it is clearly not working at all.

Both torsocks and tor were installed via dnf (version 4) at fedora 38. Any help would be greatly appreciated.

(Additional info:

  • tor browser is positively unfunctional and impossible to download atm so I only managed to get tor and torsocks, rather than tor-browser.
  • I tried this in ubuntu derived pop os distro before and it worked after not working in first 3 hours. No idea why.)

1 Answer 1


torsocks does not provide ICMP that is used for ping command because there's only TCP and UDP are available in SOCKS protocols family, but in Tor only TCP supported. So there's no way to do anything via ICMP via Tor

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .