I am trying to do some research for my school thesis related to the Tor network, and I need to specify and use only one guard relay that I own while using the Tor browser. I tried to specify it with the EntryNodes option in torcc config file, but with no success. Because my relay is new (47 hours now), it's not yet relaying traffic, therefore I tried to connect to any other guard node, just to confirm that this option is possible. I tried to use an IP address of one relay, the IP addresses of 20 TOP relays, and one or more fingerprints of relays, but no circuits were created. I for example tried:

EntryNodes $35F5A0B2F017FD09F7EBF33A565A53D8EB2C9272
StrictNodes 1

Circuits were only created in case I used country code in the EntryNodes option, such as EntryNodes {ca}.

I also tried MiddleNodes and ExitNodes options with specific IP addresses of relays and as well with fingerprints of these relays - everything worked fine and circuits were created, so I do not understand what might be the problem with the EntryNodes option. After every restart of the Tor process, according to the Nyx tool, it gets bootstrapped to 75%, then continuously print

Failed to find node for hop #1 of our path. Discarding this circuit.

I tried to turn on as much debug info as possible, but could not understand anything more than the path creation is not possible. I even tried to create circuits with no configuration, then take used guard nodes from created circuits and put their IP address in the EntryNodes option, but no circuits were created after the restart of the Tor process, so I don't really understand what might be the problem. The option to specify entry nodes with fingerprints is stated in Tor documentation, and I have also found a few similar examples on the internet, so it should be possible. My Tor version is and I am using the flatpack version tor browser (was not able to install the normal version due to an installation error) on Fedora 34.

Thanks for any help.

1 Answer 1


So the problem seems to be in the Tor browsers itself. It is using its own tor process, which as it seems, is not working properly in some cases (maybe it's only the flatpack version). I tried to use the "original" Tor process, which has config placed in /etc/tor/torrc and the EntryNodes option worked without any problems. In case someone needs to use this option with the Tor browser, a possible solution could be to set up the browser to work with the other Tor process.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .