0

I've been trying for hours to use Tor, but it always closes briefly after opening. I've checked through task manager and it seems to actually launch for a moment. I've already set it to run as Administrator. The Windows version in cmd gave me a blank line, so I've installed the Linux instead and used the --verbose option, and it tells me "Cannot load XPCOM" (output shown below). I've found online that Webroot's the culprit, but I don't have Webroot, nor have I downloaded any antivirus software. I've even tried turning off some Windows Defender features, but I didn't notice any difference.

$ ./start-tor-browser.desktop --verbose

Launching './Browser/start-tor-browser --detach --verbose'...
XPCOMGlueLoad error for file /mnt/c/Users/username/Desktop/tor-browser_en-US/Browser/libxul.so:
libdbus-glib-1.so.2: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

Update: I've tried using Brave instead. It worked for about 5 seconds, then stopped. Now, each time I launch it, I get the same exact issue as with Tor. I've tried turning Windows Defender off and running it as Administrator just like before, nothing changed.

Edit: I should probably mention that firefox doesn't work either.

0

1 Answer 1

0

It seems you have a library missing. I guess these commands will help you out with the problem.

sudo apt-get update
sudo apt-get install libdbus-glib-1-2

After installing libdbus-glib-1-2 try restarting your tor browser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.