1

I'm a newbie to Tor so maybe I'm doing something wrong.

I installed Tor in a Raspberry Pi Zero W, connected to the local network, and modified the /etc/tor/torrc file so that it can be accessed only by members of my LAN.

I tested and it works:

curl --socks5 alarmpi:9050 --socks5-hostname alarmpi:9050 -s https://check.torproject.org/api/ip
{"IsTor":true,"IP":"xx.xx.xx.xx"}

Then I tried to setup the IRC client irssi to connect to LiberaChat onion service.

I followed the official guide, where it is specified to add this entry to torrc:

MapAddress palladium.libera.chat libera75jm6of4wxpxt4aynol3xjmbtxgfyjpu34ss4d7r7q2v5zrpyd.onion

I added palladium.libera.chat as server to irssi with my self-signed certificate, previously loaded into the IRC, and set the SASL EXTERNAL authentication mechanism to the network where the server was added.

I started irssi with torsocks

# Had to specify the ip because torsocks gave me an error with the hostname
torsocks -i -a 192.168.10.5 -P 9050 irssi

and then tried to connect to LiberaChat onion service

/connect -network Libera palladium.libera.chat

but it gave me this error: ERROR torsocks[14686]: Unable to resolve. Status reply: 4 (in socks5_recv_resolve_reply().

Changing palladium.libera.chat to an ip address (10.40.40.40), both in irssi and Tor configuration, solved the problem

7:06 -!- Irssi v1.2.3-1 - https://irssi.org
17:06 -!- Irssi: Looking up 10.40.40.40
17:06 -!- Irssi: Connecting to 10.40.40.40 [10.40.40.40] port 6697
17:06 -!- Irssi: Certificate Chain:
17:06 -!- Irssi:   Subject: CN: palladium.libera.chat
17:06 -!- Irssi:   Issuer:  C: US, O: Let's Encrypt, CN: R3
17:06 -!- Irssi:   Subject: C: US, O: Let's Encrypt, CN: R3
17:06 -!- Irssi:   Issuer:  C: US, O: Internet Security Research Group, CN: ISRG Root X1
17:06 -!- Irssi: Protocol: TLSv1.3 (256 bit, TLS_AES_256_GCM_SHA384)
17:06 -!- Irssi: EDH Key: 253 bit Unknown
17:06 -!- Irssi: Public Key: 4096 bit RSA, valid from Dec 11 23:30:38 2021 GMT to Mar 11 23:30:37 2022 
          GMT
17:06 -!- Irssi: Public Key Fingerprint: xxx (SHA256)
17:06 -!- Irssi: Certificate Fingerprint: xxx (SHA256)
17:06 -!- Irssi: Connection to 10.40.40.40 established

I really don't know why the logical address did not work while the ip did. Maybe I'm missing something.
How can I solve?

2

irssi looks like it very strictly only works with real fqdn names that it can resolve directly with DNS. It works with socks4 but not with socks5 so you can't use the tor proxy directly.

The official guide works great with hexchat, but irssi isn't mentioned and it looks like it's not compatible. With that said a quick google search shows that there is a version of irssi that supports socks5, but you have to compile it yourself from source.

I would suggest using hexchat instead. It has socks5 built-in and it works very well. If you're dead set on using a cli irc client, there's always emacs (not kidding, it works).

2
  • Thanks for the reply. Are there any security concerns using SOCKS4 instead of SOCKS5? Now I got used to irssi so I'd rather not change client.
    – dems98
    Jan 9 at 21:50
  • 1
    SOCKS4 doesn't have DNS lookup so it will always use external DNS. Since external DNS can't find onions services, it will always fail. SOCKS5 can use DNS inside the proxy. So rather than asking an external DNS server, a piece of software using SOCKS5 with tor will ask tor instead of DNS and then it can find onion services.
    – JSEvans
    Jan 10 at 6:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.