1

I am running Fedora 35 Workstation.

With Tor Browser 10.x everything was fine.

After update to Tor Browser 11.0, Tor Browser displays the tofu substitute characters in all places instead of the actual characters.

This is how I see the settings menu:

enter image description here

1

Found working solution (at least for Fedora 35)
go into font.config file line 37 in the home folder
~/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser/TorBrowser/Data/fontconfig/fonts.conf
and substitute
<dir>fonts</dir>
for
<dir prefix="relative">fonts</dir>
and start Tor browser again and it will display normal characters.
For other distros or Windoze just search for the TorBrowser/Data/fontconfig folder to find font.config file in the user's folder and should be fine.

1
  • Thanks, it worked great! I have the standalone version, so for me the file to modify was Browser/TorBrowser/Data/fontconfig/fonts.conf Nov 18 at 18:08
0

I've seen similar results on Fedora 34.

This may be the same issue reported in the Tor support forums, which is also being tracked in their issue tracker. I'm seeing the same tofu substitute characters you are, but also the "enlarged tabs" shown in the first screenshot in the forum post: enlarged tabs

...which is what makes me think the two are related.

It looks like a fix is coming soon, according to that issue.

3
  • why the issue tracker talks about "Browser chrome"? Doesn't Tor uses Firefox? Nov 11 at 20:55
  • I assume they're talking about userChrome.css, which is a style sheet used to configure the user interface. From that article: "[userChrome.css] has nothing to do with Google Chrome. “Chrome” refers to the user interface of the web browser, which is what Google Chrome was named after." Nov 12 at 21:14
  • Apparently it wasn't that issue. I just updated to 11.0.1, which should fix that issue has explained in the changelog "* Bug 40690: Browser chrome breaks when private browsing mode is turned off [tor-browser]", but the issue is still there Nov 18 at 18:04
0

checking and unchecking “Always use private browsing mode”, as suggested in that support link doesn't help. I tried both ways, I tried to remove tor, and remove all user settings, but no luck.
Using Fedora 35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.