0

I'm new to Tor and installed it and torsocks on a fresh ubuntu machine. I've set up and configured the torrc file with the following parameters:

ExitNodes A0C59410B9030AC1385C4CA44C8DBFE13AF4BC9B
StrictNodes 1

my aim is to use an exitpoint in the UK to access UK traffic, I have previously also tried:

ExitNodes {gb}
StrictNodes 1

However, when I check what my IP is using the command:

curl --socks5 127.0.0.1:9050 https://check.torproject.org |& grep -Po "(?<=strong>)[\d\.]+(?=</strong)"

the IP address that I get back is not in the UK. it usually ends up being an IP in France or Germany. I have of course also restarted the tor service through terminal but that does not make any difference either. I was under the impression that it would try to connect to the specified endpoint or timeout otherwise. Am I missing something obvious? None of the other similar questions that have been asked about this previously are not working for me either.

I was using tor version 0.3.* but I tried upgrading to 0.4.5.8 and am still running into the same issue.

2
  • (Just a note, StrictNodes does not apply to ExitNodes.)
    – Steve
    May 14 at 20:36
  • Well, that explains one thing at the very least.
    – GreenGodot
    May 16 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.