0

My ISP don't block Tor.So last weeks I have problem to connect tor browser. I have a raspberry pi that run tor. The below web page show my setup.

https://pimylifeup.com/raspberry-pi-tor-access-point/

Then raspberry takes internet over wifi from router then connect over wifi to my laptop. I use this setup over 2 years and WORKS PERFECT, but 3 last weeks I have this error message when connect tor browser.

[WARN] Problem bootstrapping. Stuck at 10% (conn_done): Connected to a relay. (TLS_ERROR; TLS_ERROR; count 10; recommendation warn; host 42949C1EC1FEC5E30197E269FE7850CCA2FD0C0D at 51.75.54.88:443)

I tried to block above IP but the problem stills continue with other ip. The very strange is that sometimes it works with the above ip, and sometimes show the above problem the same ip. This problem stills with other ip.

I think the problem is Common log error #3: Failed to complete TLS handshake from this page:

https://support.torproject.org/connecting/connecting-2/

but if I open via ssh terminal from my linux machine to raspberry and I run sudo -u debian-tor nyx and inside nyx press one or two times "n" change identify then tor-browser works.

When I connect from my linux OS directly from my REAL IP (without I use rasbperry pi) to tor browser , everything is perfect. I don't use firewall.

Thank you

4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.