1

I wonder if anyone here has tried this before and maybe could give me some advice. My internet connection at home is dual stack lite so I don't have a public IPv4 address and therefore can't setup a TOR relay. But I have a VPS which of course has a public IPv4.

I have some experience with tunneling between my VPS and home server using reverse SSH. I can connect to a website or cloud hosted on my home server through these tunnels via the IPv4 of my VPS without a problem. But I can't manage to get this working with the TOR relay.

I suspect it to be a problem with me not being familiar with the TOR configuration. My setup is like this: All traffic coming to port 9001 of my VPS is tunneled to port 9001 of my home server. In the config file I declared the IP of my VPS. But it doesn't work. After starting the TOR service it fails the check if the port is reachable from outside.

Any advice on this? Thanks in advance.

I posted this on /r/TOR too. Concerning a switch to real dual stack: No, this would cost me 30€/month extra. The whole thing is more about the curiosity of getting this to work than about needing it. If it works, fine, my relay will be up and running. If it doesn't, I could set up a relay on my VPS (although the 512MB RAM seem to make this a bit critical). I don't need a public IPv4 for my home connection, so please don't advice me to change my subscription in that regard.

2
  • I don't see why this wouldn't work (there may be an issue involving NETINFO cells and canonical addresses, but I don't think this is important). Can you post details about your torrc file and the SSH flags you're using?
    – Steve
    Mar 6 at 19:28
  • ssh -p 22 -N -R 9001:localhost:9001 root@ip_of_vps In torrc I set ORPort 9011 and then I don't really know what to do with the Address option. If I leave it commented out or use something like localhost, TOR binds to my non-public DS-lite IPv4. If I set it to the IP of the VPS TOR binds to it but then hangs at the "Now checking whether IPv4 ORPort ip_of_vps:9001 is reachable...".
    – MaxthonFan
    Mar 6 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.