1

Not sure if this is a problem for others or just that my own browser is not configured properly. But is anyone else unable to browse DuckDuckGo when they disable javascript/ turn security-level to safest.

0
3

I am not sure, but I am guessing you might be encountering a blank page?

This is copy-pasted from my reddit post: https://old.reddit.com/r/TOR/comments/lmrdk6/tor_browser_safest_security_and_duckduckgo/

How to fix it

Enable noscript in the NoScript options:

  • Click on the hamburger menu (three bars in the top right corner)
  • Add-ons
  • The three dots for NoScript
  • Preferences
  • Click the option for noscript between ping and other.

Otherwise if you have NoScript in the bar you can just:

  • Click on the extension
  • Click on the third icon from the left in the top
  • Tick the noscript option.

Or enable noscript for just DuckDuckGo:

  • Click on the extension
  • Change duckduckgo.com from standard (first icon) to custom (fifth icon).
  • Tick the noscript option

Some more details.

NoScript 11.2.1 added a new option for whether elements should be shown on pages. Because Tor Browser overrides NoScripts standard options and noscript hasn't been added to the list that should be enabled we are now seeing this problem.

If you change security level, or you restart the browser, Tor Browser will disable the noscript option (because of how it does NoScript options) so you will have to do the above (again).

It seems NoScript enables the noscript option when it gets updated. So if you have the security slider to safest before the update NoScript will do all the work for you. (Until you restart the browser)

 

I have opened an issue on the gitlab: https://gitlab.torproject.org/tpo/applications/torbutton/-/issues/40030.

Edit 24/Feb.: I have created a pull request to fix this: https://gitlab.torproject.org/tpo/applications/torbutton/-/merge_requests/37
it should be fixed in the next release.

0

But is anyone else unable to browse DuckDuckGo when they disable javascript/ turn security-level to safest.

Yes, I can confirm this issue occurs in the latest Tor Browser, version 10.0.13.

Building on HackerNCoder’s answer, I also confirmed that resetting NoScript’s options (using NoScript’s “reset” option) enables the “noscript” option and that changing the Tor Browser security level resets all the options to Tor Browser’s values. Finally, enabling the “noscript” option gives us that familiar message:

You are being redirected to the non-JavaScript site.

And DuckDuckGo works perfectly!


Warning: Changing any Tor Browser options, including the NoScript options discussed above, reduces your anonymity. This is because this makes you look different to other Tor Browser users, and anything that makes you look different can help identify you.

Tor Browser version 10.0.13 was a bug fix specific to Linux. Presumably this is why it does not fix the NoScript bug discussed here. The next “normal” release should fix it.

0

You can also avoid all the hassle and use either:

3
  • Unfortunately, if you try to get the equivalent onion service by accessing https://html.3g2upl4pq6kufc4m.onion/, it serves an invalid certificate. The correct URL is https://3g2upl4pq6kufc4m.onion/html/. Mar 4 at 15:01
  • This post is useful, but it is technically not an answer to the question posed by the OP. It is very easy to edit it so it is an answer, so rather than flag it, I am leaving this comment in the hope you will edit this post. Mar 4 at 15:05
  • @BrianDrake I have updated it. Thank you! Mar 7 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.