3

When I try to open the Tor bundle on a Mac, a box pops up and says "A copy of Firefox is already open. Only one copy of Firefox can be open at a time." But I don't have Firefox open.

  • Same problem: downloaded latest bundle for Mac (OS X Vers. 10.9.3), ran install, nothing much happens then error message pops up "Close Firefox - A copy of Firefox is already open. Only one copy of Firefox can be open at a time." I don't even have Firefox installed on my system! Thoughts? – user1908 Jun 7 '14 at 1:25
  • I have the same issue and I don't have firefox installed at all. Never installed it on this computer -Macbook Pro running OSx 10.9.3 latest at the moment- but it still says a copy is already open. – user3183 Jul 15 '14 at 2:22
  • I saw something about this on an Apple forum, but I can't find it now. As I recall, the problem is that the Tor browser folders aren't owned by the proper user, and/or don't have the proper permissions set. And so the folder appears locked, which normally means that Firefox is running. – mirimir Jul 16 '14 at 10:16
  • Also see this question: tor.stackexchange.com/questions/931/…. The third comment to the first answer may be relevant. – mirimir Jul 16 '14 at 12:49
2

I had exactly the same problem. I found out that it has not actually anything to do with another instance of Firefox (I don't even have it installed) it turns out that it has something to do with the files being locked when they are in you applications folder. To fix the problem just move the application into another folder (downloads or documents) and then open from there.

  • brilliant solution to the problem! i was having problems with this on my iMac and dragging tor browser to applications solved the problem. thanks elliot – user3584 Sep 8 '14 at 6:57
1

The tor browser bundle is in a sense a modified version of FireFox. Due to this, when your computer is telling you only one FireFox can be run at a time, it's because Tor counts as a FireFox app.

1

That may have happened because Firefox hanged or is taking to long to close. Access your task manager and terminate Firefox's application. That will loose you no data and will allow you to run Firefox again.

It's probable that it's just taking a bit longer to close, though, so waiting a bit will probably fix the issue (like a few seconds).

You may also try to create a new profile.

See:


There is also some suggested solution at Support Mozilla:

  1. Launch My Computer or Windows Explorer.
  2. Choose menu 'Tools' -> 'Folder Options'
  3. Click the 'File Types' tab.
  4. Scroll down to find 'URL:HyperText Transfer Protocol' (under the File Types column) and make sure it's highlighted.
  5. Click the 'Advanced' button.
  6. In the 'Actions' box make sure that 'open' is highlighted (click on it if necessary)
  7. Click the 'Edit' button.
  8. Uncheck 'Use DDE', click the Browse button and browse to Firefox.exe on your system, and click OK. [Updated for clarification, sorry about the earlier omission.] If you get a "file not found" message, browse to Firefox.exe and click OK.
  9. The path to Firefox.exe should now appear in the 'Application used to perform this action' box.
  10. Go to that 'Application used to perform this action' box, and add '-url "%1"' at the end, without the single quotes, so that it reads e.g. (on my computer at least) "C:\Program Files\Mozilla Firefox\firefox.exe" -url "%1" - with the double quotes!
  11. Click OK again.
  12. Repeat the process with the file type 'URL:HyperText Transfer Protocol with Privacy'

Not the answer you're looking for? Browse other questions tagged or ask your own question.