0

I've been trying to get IVP6 running on my tor bridge, and ever since I've had this great idea it's been a Mount Kilimajaro vertical climb with me not getting much past the base of the mountain.

I am installing on a Digital Ocean Droplet (Ubuntu 20.4). IVP6 has been enabled on the site.

Secondly I used the Tor Configator to set up the torrc file. Below is the file from Tor Configator, somewhat modified by me.

ORPort 6XXX
ORPort [2604:a880:400:d0::1998:a001]:auto
ExtORPort auto
SocksPort 0
BridgeRelay 1
Nickname 
ContactInfo 
ServerTransportPlugin obfs4 exec /usr/bin/obfs4proxy
ServerTransportListenAddr obfs4 0.0.0.0:8XXX
Log notice file /var/log/tor/notices.log
ExitPolicy reject6 *:*, reject *:*
RelayBandwidthRate 
RelayBandwidthBurst 
#AccountingStart month 1 00:00
#AccountingMax 1 GB
DisableDebuggerAttachment 0
ControlPort 9051
CookieAuthentication 1

Repeated error after many tries:

Dec 02 07:15:43.393 [notice] Opening Control listener on 127.0.0.1:9xxx
Dec 02 07:15:43.393 [notice] Opened Control listener on 127.0.0.1:9XXX
Dec 02 07:15:43.393 [notice] Opening OR listener on 0.0.0.0:6969
Dec 02 07:15:43.393 [notice] Opened OR listener on 0.0.0.0:6969
Dec 02 07:15:43.393 [notice] Opening OR listener on [2604:a880:400:d0::1998:a001]:0 <A port number was assigned here, came back as zero
Dec 02 07:15:43.393 [warn] Could not bind to 2604:a880:400:d0::1998:a001:0: Cannot assign requested address
Dec 02 07:15:43.393 [notice] Opening Extended OR listener on 127.0.0.1:0
Dec 02 07:15:43.393 [notice] Extended OR listener listening on port 4XXXX
Dec 02 07:15:43.393 [notice] Opened Extended OR listener on 127.0.0.1:4XXXX
Dec 02 07:15:43.393 [notice] Closing partially-constructed Control listener on 127.0.0.1:9XXX
Dec 02 07:15:43.393 [notice] Closing partially-constructed OR listener on 0.0.0.0:6XXX
Dec 02 07:15:43.393 [notice] Closing partially-constructed Extended OR listener on 127.0.0.1:4XXXX
Dec 02 07:15:43.393 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Dec 02 07:15:43.393 [err] Reading config failed--see warnings above.

The IVP is the public address assigned by Digital Ocean to the Droplet. The range is from a001 - a001 F

I've tried following online websites and I have learned that much of that information is or is not trustable. Hard to know when you are new to Tor.

Any help would be appreciated, and thank you!!

3
  • Is your droplet's networking set up for IPv6? If you run the command ip addr, do you see your IPv6 address there?
    – Steve
    Dec 2 '20 at 20:38
  • Hi Steve thank you for your help Here's what ip addr says: 2. eth0
    – adriann
    Dec 3 '20 at 6:30
  • It doesn't look like your comment posted correctly. Can you edit your question and paste it there instead?
    – Steve
    Dec 3 '20 at 15:14
0

If you are trying to setup IPv6 only relay then forget about it - it WILL NOT work. See A Tor relay operators IPv6 HOWTO for more.

Specifically the above page says:

There is currently no way of running an IPv6 only relay. Your relay will have to publish both an IPv4 and an IPv6 OR port. This limitation will go away but note that your relay will need to be able to make outgoing IPv4 connections for a foreseeable future.

The page mentions this issue tracker: #5788: Add support for relays without an IPv4 address

Additionally, if I read the tor man page correctly, you can specify both (optional) IP address and numeric port for ORPort option or single value of auto. Therefore, your configuration entry:

ORPort [2604:a880:400:d0::1998:a001]:auto

is invalid. Your probably can do the following:

ORPort auto IPv6Only

to limit ORPort to IPv6 only and have automatic assignment.

8
  • I don't think this is an IPv6-only relay, as it's also listening on an IPv4 address (ORPort 6XXX).
    – Steve
    Dec 2 '20 at 20:31
  • If it has public IPv4 address assigned. And it is NOT apparent from attached logs that it has one.
    – Tomek
    Dec 2 '20 at 20:33
  • The issue is that the relay is unable to bind to the given IPv6 address, which is unrelated to the server having (or not having) a public IPv4 address.
    – Steve
    Dec 2 '20 at 20:36
  • That's probably the second part of my answer. Apparently auto is interpreted as 0 and this is invalid port number. Hence bind fails.
    – Tomek
    Dec 2 '20 at 20:42
  • I've tried ORPort with [IPv6]:auto and it worked on 0.4.3.7. Maybe it is older version with a bug?
    – Tomek
    Dec 2 '20 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.