0

Running Ubuntu 20.10 and I have made Tor my default browser. It works well except when I click on external links (from an application, say ULauncher or a ebook reader). Then I get an error message:

u

0

This happens, because Tor Browser does not accept remote commands by default. See here and here for details. As mentioned in the tickets, you can work around this by starting the browser with the argument --allow-remote. You will need to add this option when you start the first instance and when trying to open a link from an external application. To facilitate this, you can create a simple bash-script:

#!/bin/bash
FOLDER=$(dirname $0)
$FOLDER/start-tor-browser --allow-remote $@

Save this script in the Tor Browser folder (next to your start-tor-browser file and grant execution rights. You can then use this script as your default browser and everything should work as expected. Keep in mind though, that the developers probably had a reason to make --no-remote the default option. I think the main concern is, that apps on your system could open webpages via Tor and link your Tor identity with what they know about your system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.