0

I've set up a computer in my home just to run a relay. I have a fiber connection to my house and want to put it to good use so im trying to run tor. My server is currently running debian,(Ubuntu) as it is what im confortable with but i've also tried using FreeBSD as it is recomended for tor.

The problem im facing is that tor complains that the ORPort is unreachable. I've tried using a common port like 443, and the default, 9001. Nether of these worked as i had the same error comming up as before. The client is able to bootstrap to 100% but it fails in trying to validate my server is reachable.

I am currently behind NAT so the first thing i did was set up a port forward from external port 443 to internel port 443 on my computer. This did not result in a difference so i tried enabeling dmz so it would externally but im having no luck. I hope you guys might have a answer. Heres my torrc file:

change the nickname "myNiceRelay" to a name that you like

Nickname Brick
ORPort 443
ExitRelay 0
SocksPort 0
Control Socket 0
# Change the email address below and be aware that it will be published
Contact Info tor-operator@your-emailaddress-domain`

Thanks for the help in advance :)

4
  • There's no obvious error from your description. Make sure you have port 443 unblocked in both your computer and router firewalls, and port forwarding set up on your router. It might be possible that your ISP blocks incoming connections on port 443, so maybe try another port.
    – Steve
    Nov 20 '20 at 14:53
  • Ive checked with my ISP, They do not block port 443 and ive aldready tried on a different port, 9001. Ive set up the port forward for my router as said above.. Nov 20 '20 at 16:40
  • This still seems like a firewall / port forwarding issue, so I would try connecting to the OR port using telnet from various places. For example from localhost, then another computer on your local network, and if those work, then outside of your network. Other than that I don't have any suggestions, so hopefully someone else has more ideas.
    – Steve
    Nov 20 '20 at 17:40
  • @Steve my relay is reachable within my network. Im current on Linux so i connect via a NC connection and it worked showing me a success message with the -verbose flag. Ill try again with my external network and let you know :) Nov 22 '20 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.