0

i've been running v2 onion address for my clearweb blog for some time.However i heard that from 2021 the v2 will be removed and only v3 addresses will be working.Since yesterday i have been trying to create v3 address running to the same blog of mine, but i don't want to completely remove the v2 address yet since some people might be using it.I need both v2 and v3 address to be pointing to my blog that is hosted with nginx on my Ubuntu machine.I am really bad at codding/web server handling so i will appreciate some help.

Currently my torrc file is having:

HiddenServiceDir /var/lib/tor/blog/
HiddenServicePort 80 127.0.0.1:80

From what i read i just need to add another lines for my v3 address.There is no need for HiddenServiceVersion 3 specification, since it is default now, right?So just below the v2 lines i am adding:

HiddenServiceDir /var/lib/tor/blogv3/
HiddenServicePort 80 127.0.0.1:6667

when i reload tor i can see the hostname files are properly created.Now in nginx sites-available/enabled my current v2 service was using the default file and it looks like this:

server {
    listen 80;
    server_name blog  www.blog;
    root /var/www/blog;

    index index.html index.htm index.php;

}
  • some location rules that there is no point to show. Now i want my v3 address to point to the exactly same file folder of my website /var/www/blog. I created new file called blogv3 in the sites-available folder and copy pasted the same from the default file, just changing the server name to be my onion v3 generated address.Here is how it looked like:

    server {

      listen 80;
      server_name v3addressjhs85hsf85hs8f5hsf85shf8s5hs.onion;
      root /var/www/blog;
    
      index index.html index.htm index.php;
    

    }

I am not sure if i have to listen to 80 or 6667.When i properly reloaded the nginx and the file was copied and visible in the sites-enabled folder i waited for some time, but not only the v3 address was not opening and pointing to my blog, but now even the v2 address stopped working.Perhaps there is no need for me to create new file in sites-available/enabled, but i can just add the v3onion in the server_name and both will be working?Once i reversed and deleted everything i created for the v3, my v2 starts working once again after reload.I am obviously doing something wrong i just can't figure out what it is.I will really appreciate some help.

Thank you.

  • I'm not very familiar with nginx, but your torrc v3 address says your web server is running on port 6667 (HiddenServicePort 80 127.0.0.1:6667), but your nginx configuration for your v3 address says to run the web server on port 80 (listen 80). – Steve Nov 17 '20 at 5:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.