0

It worked a few days ago, but now it doesn't. The tor network works, I think, running tor I get:

~ >>> sudo tor                                                                
Nov 11 18:52:17.284 [notice] Tor 0.4.4.5 running on Linux with Libevent 2.1.12-stable, OpenSSL 1.1.1h, Zlib 1.2.11, Liblzma 5.2.5, and Libzstd 1.4.5.
Nov 11 18:52:17.284 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Nov 11 18:52:17.284 [notice] Read configuration file "/etc/tor/torrc".
Nov 11 18:52:17.289 [notice] Opening Socks listener on 127.0.0.1:9050
Nov 11 18:52:17.289 [notice] Opened Socks listener on 127.0.0.1:9050
~ >>>

If I run it again it says tor already running:
[warn] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?

But the browser won't open.

>>> ./start-tor-browser.desktop Launching './Browser/start-tor-browser --detach'...

and than nothing or without detach, it is also closes.

what I've tried:

  • setting RunAsDaemon=1 as to Tor browser won't open (kali roling 2016.2)
  • uninstalling, reinstalling (from tor website, from kpcyrd, from flatpak) as many recomanded.
  • disabled firewall (I don't have antivirus, I should look for one)
  • running as admin.
  • changed permissions to the tor folders (to root/tor, tried both).
  • restarted mt computer completely.
  • trying to connect through vpn (though doesn't make a difference the network works, the browser doesn't.
  • I've seem some people refer to XPCOM, webroot, setting LOGNAME, which I didn't quit get what the meaning is.

I would really appreciate any and all help.

my os is manjaro.

0

There are a bunch of issues here. First of all, you don't want to run tor or Tor Browser as root. If you only want to start the Tor Browser, then you probably don't want to be running tor at all outside of the browser, and especially not as a daemon.

First uninstall every version of tor you've installed (for example, apt remove tor, snap remove tor, flatpak uninstall tor, etc). Close the Tor Browser, and then make sure no tor processes are running using pgrep ^tor\$. If any tor processes are running, then restart your computer and make sure that no new tor processes have started.

Next delete your Tor Browser directory (note: this will delete any settings or bookmarks). Redownload Tor Browser from https://www.torproject.org/download/ and run it using ./start-tor-browser.desktop. Do not make any changes to your browser's torrc file.

If the Tor Browser still does not launch, then please update your question with more information. You list a lot of things that you've tried, and any of them could have made weird configuration changes to your system.

2
  • Thank you, it works, the difference between what I did before was killing tor that was in the background before uninstalling.
    – Adir
    Nov 12 '20 at 15:57
  • Glad to hear you got it working!
    – Steve
    Nov 12 '20 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.