0

NordVPN uses a TAP adapter, and Comodo Firewall allows you to create rules that only allows traffic originating from the MAC address of a TAP adapter.

I don't see any way to configure Comodo to ensure the Tor connections go through the NordVPN, as localhost traffic doesn't use any TAP adapters.

A solution I see it to move the Tor addresses from localhost to 10...* (Assigned IP address or gateway.)

How do I accomplish that? Or us there another solution?

I tried setting this in torrc

SocksPort 10.*.*.*:9150  (also tried 0.0.0.0:9150)
SocksListenAddress 10.*.*.*:9150

But when I start TorBrowser Comodo still asks if I want to allow a connection from tor.exe to 127.0.0.1:9150

I also tried changing this in TorBrowser, about:config

extensions.torlauncher.control_host     127.0.0.1  

to 10.*.*.*.* (My local IP address), but I get the exact same message from Comodo when I start TorBroswer (? allow tor.exe -> 127.0.0.1:9150)

This last thing also broke TorBrowser, which then refused to start. I copied the folder from a backup to restore it.

  • Why do you not want to allow connections on localhost? The Tor Browser should connect to tor.exe on localhost, and then tor.exe should connect to the guard on the internet. You want only this second connection to go through the VPN, but not the first connection on localhost. – Steve Oct 9 at 21:16
  • @Steve If the VPN drops, the Tor entry node would see the IP address. I have to enable 127.0.0.1 9150, and the internet in Comodo for tor.exe to work. If I only allow tor.exe on 127.0.0.1 9150, a Tor connection can't be made. --- I also have to allow TorBrowser the same two privileges. --- If it was the case that one only had access to 127.0.0.1 9150, and the other only had access to the internet via VPN, then there wouldn't be a problem. – Winston Oct 9 at 23:17
  • Okay I'm not understanding, probably because I'm don't know exactly what options Comodo's firewall allows. But for the question "How to configure Tor/TorBrowser to NOT use localhost?", this is not useful as tor needs to accept SOCKS connections, and these connections must bypass the VPN. – Steve Oct 9 at 23:37
  • @Steve If that's right, then I need to re-post asking how to configure Comodo to block tor/torbrowser from bypassing the VPN on the internet. – Winston Oct 10 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.