0

I'm trying to test creating a prototype hidden service with nginx on Debian.

The torrc file appears to be correct, has no problem being parsed by tor and the tor service is 100% boostrapped and running. torrc looks like this:

HiddenServiceDir /var/lib/tor/nginx/
HiddenServicePort 80 127.0.0.1:81

Nginx is also running fine and seems to be correctly configured (as per a guide) to the corresponding port. I can check the system for messages from both tor and nginx without finding anything clearly out of order, yet the generated .onion URI doesn't resolve.

How can I narrow down where the failure is occurring?

Other steps tried:

  • lots of reloading, restart, stopping, and starting the services
  • tried toggling the nginx listening port and corresponding torrc port between 81, 80, 8081, 8080
  • rebooting the server
  • making sure other servers like apache2 are not installed
  • manually running the tor command instead of as a service
  • changing the Data Directory several times and generating new .onion addresses
  • temporarily disabling ufw to make sure it's not interferring

I have a feeling if I were better with Wireshark or some packet tracer that I could narrow down the failure that way, but I'd need the steps broken down for me.

  • I don't see anything obviously wrong. You can see the website if you connect to it at 127.0.0.1:81? Are the permissions of /var/lib/tor/nginx/ correct (owned by debian-tor if using debian or ubuntu)? Can you post your tor log? – Steve Aug 20 at 2:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.