0

Switch from root to user = su usrname >Password. The problems start when I try and su to debian-tor. First I get a query for a password which it doesn't have. So I make a pass for debian-tor and enter it when I su to debian-tor. I enter whoami and the response is: user and not debian-tor. With or without a password it doesn't work. Secondly, if I su debia-tor >passwrd - sudo -u debian-tor nyx it produces a page and a half of pure gibberish. Sudo -i to root and enter nyx, it operates perfectly; and yes I understand I shouldn't run nyx as root.

How do I become debian-tor so I can operate my bridge correctly? Adriann

  • Yours look different because you changed the setting of debian-tor as you mentioned in your post. – Aviv Lo Apr 20 at 8:44
0

debian-tor is an service account (group) created by Tor during installation. It has it's shell acces set to /bin/flase which means you'll be logged out immediately when trying to login using it.

You can check it by typing sudo cat /etc/passwd | grep debian-tor

So what you have to do is to add the default user, for example ubuntu in Ubuntu operating system, to the debian-tor group. You can do it by typing sudo usermod -a -G debian-tor your_default_user

After this you'll have to edit the torrc file and add the line CookieAuthFileGroupReadable 1 and DataDirectoryGroupReadable 1in the file.

Then you'll have to restart tor, log out and login again (because you just change the user's group setting).

After that, if you type in nyx you should able to start nyx as a non-root user.

It took a while for me to figure it out as well. Hope this help.

| improve this answer | |
  • Thank you Aviv Lo! I'll give it a try. – adriann Apr 20 at 2:08
  • cat /etc/passwd | grep debian-tor = tor:x:112:116::/var/lib/tor:/home/debian-tor – adriann Apr 20 at 2:13
  • the above can't be correct – adriann Apr 20 at 2:20
  • How about getent group debian-tor – Aviv Lo Apr 20 at 8:43
  • I saw your question on the tor-relay mailing list as well. – Aviv Lo Apr 20 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.