0

I am using Ubuntu eoan. Here is what I did:

  • Uncommented #HiddenServiceDir /var/lib/tor/hidden_service/ and #HiddenServicePort 80 127.0.0.1:80 in /etc/tor/torrc
  • Restarted tor service by using sudo service tor restart
  • Ran sudo nano /var/lib/tor/hidden_service/hostname

After I ran sudo nano /var/lib/tor/hidden_service/hostname, nano didn't show any text. I also tried this with gedit, and the output was the same. So I opened file explorer and went to /var/lib/tor, and the directory was empty. What did I do wrong and how do I fix this?

  • 1
    Could you look into /var/log/tor/ if there are any files (log, notices.log, etc.)? If so, please open it. Are there any lines which start with WARN? Please edit your question and copy them into the question. They can help to find the issue. – Jens Kubieziel Apr 14 at 9:57
  • @JensKubieziel I checked and the directory is empty, but it is a directory – TheRealTengri Apr 15 at 8:44
  • Please run sudo journalctl -ef _SYSTEMD_UNIT=tor@default.service and restart Tor (sudo systemctl restart tor). Do you see error messages? – Jens Kubieziel Apr 15 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.