1

I am allowed 3646 GB of transfer in a month on my droplet, and the droplet is at 3746 which means I have to pay an 'overage' besides the cost of each droplet (2).

torrc:

Current bandwidth is at 100 KB and the burst is set at 200 KB.

NYX is set at 40 mb/40mb and I never did understand the purpose of having dual settings.

How do I calculate bandwidth/burst rate to stay within the 3646 thresh hold??

Thanks anybody for help with this :-)

 Adriann
1

Rather than setting a bandwidth/burst, consider enabling the bandwidth accounting:

https://2019.www.torproject.org/docs/tor-manual.html.en#AccountingMax

Limits the max number of bytes sent and received within a set time period using a given calculation rule (see: AccountingStart, AccountingRule). Useful if you need to stay under a specific bandwidth. [...] If you have bandwidth cost issues, enabling hibernation is preferable to setting a low bandwidth, since it provides users with a collection of fast servers that are up some of the time, which is more useful than a set of slow servers that are always "available".

For example:

AccountingMax 3395 GBytes
# 3646 GB = 3395 GiB
AccountingRule out
# only count outgoing traffic
AccountingStart month 1 0:00
# start on the first day of each month

To set the bandwidth/burst rate, let's assume that your DigitalOcean bandwidth limit is 3646 GB for outgoing data only, and that incoming is unlimited (this used to be the case, but their help page doesn't mention incoming data anymore). Let's also assume that your units use decimal prefixes since you used GB and not GiB and the decimal value is lower (so you don't accidentally go over your limit because of unit confusion).

There are 2,678,400 seconds in 31 days and 3646000000000 B in 3646 GB. This works out to a maximum bandwidth rate of 1361260 B/s. Tor's configuration file uses binary prefixes, so 1361260 B/s is equivalent to about 1.29 MiB/s.

Setting the following lines in your torrc configuration should make it unlikely that you exceed your limit.

BandwidthRate 1.29 MBytes
BandwidthBurst 2 MBytes

But this is specifically the case that the bandwidth accounting was designed for, so I'd recommend using those (or slightly higher) bandwidth values, but also setting AccountingMax.

You should also disable your Nyx bandwidth settings in this case.

| improve this answer | |
  • How to disable bandwidth in nyx. I use it's default settings.? – adriann Mar 3 at 22:37
  • @adriann If you don't change anything in Nyx I think it should be fine, but I've never used Nyx. Could you update your post to show where Nyx says "40 mb"? And if it still says this, maybe it would be good to make a new question asking about this so that someone who uses Nyx will see it. – Steve Mar 4 at 1:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.