0

Firefox Nightly recently updated to the new UI they beta'd under the Firefox Preview moniker. The proxy settings I had in about:config got wiped out but reinstating the exact same settings is getting me the following message in the browser, presumably from Orbot itself:

This in HTTP CONNECT tunnel, not an HTTP proxy.

It appears you have configured your web browser to use this Tor port as an HTTP proxy.

This is not correct: This port is configured as a CONNECT tunnel, not an HTTP proxy. Please configure your client accordingly. You can also use HTTPS; then the client should automatically use HTTP CONNECT.

See https://torproject.org/documentation.html for more information.

These are the about:config settings I've currently configured:

network.proxy.http = 127.1
network.proxy.http_port = 8118
network.proxy.socks = 127.1
network.proxy.socks_port = 9050
network.proxy.ssl = 127.1
network.proxy.ssl_port = 8118
network.proxy.type = 1

Orbot itself also shows it's active on those ports: enter image description here

On the same device, F-Droid configured to use Tor also functions without issue. Granted, I can't see what ports it uses by default, but such settings has gone unchanged before or after the aforementioned Firefox update.

0

Never mind, I solved it: removing network.proxy.http settings did the trick. Perhaps I didn't have this configured previously or the old Firefox Nightly automatically preferred the HTTPS proxy over the HTTP one and the behavior changed after the update, I don't know. Either way, there's no issue any more and everything is functioning as expected.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.