0

I have a question about using Tor.

I have built a tor server on centos7.

To configure the access country, I set ExitNodes by referring to the manual. And download geoip and set GeoIPFile path(/etc/geoip/geoip).

Until last week, the exit node (country) was well set, but suddenly an error occurred from this week. There is an error in setting the exitnode country. So I'm checking the server, and geolite2 has changed the download policy since December 19th. Previously, GeoLite2-Country.mmdb was downloaded from the public url(https://geolite.maxmind.com/download/geoip/database/GeoLite2-Country.mmdb.gz), and mmdb-convert.py was used to configure Tor's GeoIPFile(python3 mmdb-convert.py GeoLite2-Country.mmdb).

Since 2020 years, however, the download method has been changed to a free license after signing up. So after maxmind membership, I downloaded the file (GeoLite2-Country.tar.gz), extracted it, converted it to GeoLite2-Country.mmdb, and configured it.

By the way, the exit node country is still not selected and the Tor server does not work. No matter how I check the server, the difference is that the geoip part, I do not know why it can not be configured.

Is anyone experiencing the same problem as me? If you know how to solve it, please reply.

  • i don't have an answer to your question, but you should be aware that by limiting your exit nodes to those in some subset of countries you're not getting the full privacy benefits from tor. – tao_oat Jan 7 at 14:33
-1

@tao_oat I can't comment because of lack of reputation.

Sometimes I need a specific country ip, so I configured the exit node like that. But to protect my privacy, I'll need to add an option to select entire country. Thank you for your good feedback.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.