0

I'm running Ubuntu 18.04 server, headless and installed tor using the debian instructions on the tor project. However, nyx will not run to show me tor connection information, when I enter nyx I receive the message: Unable to connect to tor. Maybe it's running without a ControlPort?

However, I can see tor running when I run top.

   921 root      20   0   75448  19400   6356 S   0.3  0.5   0:03.12 tor  

But, when I run systemctl | grep tor I see:

● tor.service            loaded active exited    Anonymizing overlay network for TCP (multi-instance-master)                  
● tor@default.service    loaded failed failed    Anonymizing overlay network for TCP                

I've configured my 'tor service' in /usr/share/tor/tor-service-defaults-torrc and that file's contents are:

DataDirectory /var/lib/tor
PidFile /run/tor/tor.pid
RunAsDaemon 1
User debian-tor

ControlSocket /run/tor/control GroupWritable RelaxDirModeCheck
ControlSocketsGroupWritable 1
SocksPort unix:/run/tor/socks WorldWritable
SocksPort 9050

ControlPort 9051
CookieAuthentication 1
CookieAuthFileGroupReadable 1
CookieAuthFile /run/tor/control.authcookie

Log notice syslog

Any help to get nyx working and improve my tor implementation is appreciated.

0

I found the answer in this post the issue was that another tor service was running, blocking access to the control port. The following code fixed the problem:

sudo netstat -plnt | fgrep 9050

To find the other service hogging the control port.

sudo killall tor

To kill all tor processes.

sudo systemctl start tor.service

Then I ran journalctl -xe to make sure that tor booted correctly.

New contributor
Salt_from_the_Sea is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.