0

how do I re enable blocking Javascript ( my security is already set too safest )

2
  • Here's an easy test. Set your browser to "safest" and go to: whatismybrowser.com/detect/is-javascript-enabled. It is says "yes" they we can troubleshoot further. If it says "no" then it is blocking javascript correctly. If you are still concerned, uninstall Tor Browser and reinstall. – JSEvans Oct 30 '19 at 18:44
  • Please add more details and information about your issue. Did you try uninstalling and reinstalling the Tor Browser. Have you tried the solution provided by the answer below? Please update the question with this, because currently, the information you have provided is very little and it is hard to figure out how to actually solve the problem (we can only give options, not solutions). Thank you. – Swangie May 31 at 20:08
2

Strange to see this problem, because the "safest" security level is supposed to block Javascript with the help of NoScript.

Anyway, you can do an additional JS block by visiting about:config (enter this in the URL bar or copy&paste about:config?filter=javascript.enabled). Accept the warning and proceed with caution. Then, start searching for 'javascript' and set javascript.enabled to false.

Here's a screenshot of what it looks like (The blue line is that what we're changing):
enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.