0

I'm not a techie. Hope someone can tell me in dumbese where exactly, in what program, what UI, to look for what setting(s) to toggle whatever is making Tor grumpy. Had trouble getting Tor working with Firefox in the first place months ago as I don't know ports from proxies. Since then it's worked fine, with NoScript set to block most scripts by default (I mostly read.) I had the latest version of Tor & Firefox ESR 60.9.0.75, everything set to auto-update.
Oct. 5 I removed NoScript, which was not showing any configurable UI, to reinstall it. I accidentally removed the Tor button. That caused Tor not to launch, at least not in a form I recognized. It looked like plain Firefox. I couldn't find Torbutton available on its own to download/reinstall.
I tried a system restore, no good.

Finally I went to the Downloads folder where all the originally downloaded TOR files still are - in another user account - and just copied them to my usual user account Download folder, deleting and replacing the TOR files I had originally copied there from the same source.
Now the Torbutton was there and did open the TOR browser. But it looked wrong: There were no circuits evident.

I've tried some of the suggested Tor & Ff troubleshooting: restarting in safe mode, restarting with addons disabled, checking some of the settings. I don't have bookmarks, or history enabled. There's nothing evidently wrong with the wireless router or connection - although the wireless driver is dated 2009! I have a reason, yes, for not having updated the drivers etc. yet, so I hope to try other remedies first.
I tried Restoring back closer to the point I had restored from, since it showed a Firefox update had been affected - but, I realized, not the Firefox program that's in the Downloads folder with Tor - only the one in c:/programs, version 69 back to 68, Quantum. So doing a restore had not affected the Tor prob the way I'd hoped.

I tried Tor again, and now it's worse: I get a message saying something like "Firefox is trying to connect via a Proxy that won't allow it." No circuits, no Noscript or HTTPS Ev, & it doesn't connect to ANY sites.

I wonder if I messed up parts of Tor updates, restoring and re-restoring again. Those do take place in the Tor files, in the Downloads folder...
I would have tried deleting all my Tor files, downloading and installing again; but getting it running the first time seemed like such a stroke of luck. Any instructions always presume knowledge of where things are and what they're called, and leave out those bits.

So- there it is. Hope someone sees something glaringly obvious here.
Dell Latitude 2009 dual core 2 GB laptop, 32 bit Windows 7 SP1.

Thanks in advance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.