0

Running 64-bit Linux Mint 19.1, Cinnamon 4.0.10, on 2.4GHz Intel Q6600 quad core w/8GB of RAM.

TOR browser was taking 10-15 minutes to load so I followed TOR's instructions and deleted the folder "tor-browser_en-US", then reinstalled from CLI using sudo apt install -y torbrowser-launcher. Not only did it still take >10 minutes to load, it came back with all my previous add-ons and settings. Something else obviously needed to be deleted so I deleted every directory or file I could find related to Tor (with the exception of "non-operational" files like icons and such).

That went on for quite a while and when I was satisfied I'd done all the damage I could, I tried reinstalling. Then I got this:

$ sudo apt install -y torbrowser-launcher
Reading package lists... Done
Building dependency tree      
Reading state information... Done
torbrowser-launcher is already the newest version (0.2.9-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

It says it's installed so I tried launching it, and got this:

$ torbrowser-launcher %u
Command 'torbrowser-launcher' not found, but can be installed with:
sudo apt install torbrowser-launcher

Except that's the command I already ran. But sure enough, "which torbrowser-launcher" returns no response.

So apparently I've deleted enough files to prevent it launching but not enough files to give it to understand it's uninstalled.

Any ideas how to proceed?

  • Running "apt purge torbrowser-launcher" stopped it reporting Tor already was installed but when I run the same install as before from CLI it hangs and times out (after downloading) while trying to verify the signature. – bobsnephew Sep 27 at 2:03
  • it seems that you have messed up your package-system. no idea if it is FUBAR... this may be easier to tell, if you can tell exactly what you have deleted. but IMHO this question fits better at Unix & Linux or perhaps Super User. – DJCrashdummy Sep 27 at 6:52
  • 3 things i can tell you in general: 1) never ever work with root privileges and especially don't delete files owned by root, except you really know what you are doing! || 2) always use a package manager to uninstall software (especially if you installed it with a package manager)! || 3) i'm pretty sure you just had to delete your profile (thats where all your settings, addons etc. are stored)... and this is somewhere located in your home directory, so no root required and no risk to mess up your system. - but for now i've no idea where exactly the Tor-profile is stored. – DJCrashdummy Sep 27 at 7:04
  • Tor Project itself advises not to use a package manager but to simply delete the files. Anyway, I downloaded the tarball file from torproject.org and installed it manually. Once I had it tarted up I shut it down and restarted it. After about 25 minutes, the same message comes up about installing Tor for the first time (but it was already installed) and it's hung at "verifying Signature." – bobsnephew Sep 27 at 16:30
  • I finally cleared it up using instructions from here: io.bikegremlin.com/11906/tor-browser-linux Start time is reasonable so I suppose I'll go through the add-ons I use and reboot after each individual modification to try to isolate the culprit. – bobsnephew Sep 28 at 0:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.