0

I am having a problem migrating an url (address) onion on a new server.

On my new server I have a first url (torrc) (which I generated on this new server) :

HiddenServiceDir /var/lib/tor/hidden_service/
HiddenServicePort 80 127.0.0.1:80

and configure as follows on 000-default.conf on apache (etc/apache2/sites-available/):

<VirtualHost 127.0.0.1:80>

ServerName MyAdressOnionV3.onion

ServerAdmin webmaster @ localhost
DocumentRoot /var/www/

Header always append X-Frame-Options SAMEORIGIN
Header set X-XSS-Protection "1; mode = block"
Header always set Strict-Transport-Security "max-age = 2592000; includeSubDomains; preload;"
</ VirtualHost>

My new server is working well.

but when I try to add my old url, no more domain works

HiddenServiceDir /var/lib/tor/hidden_service/
HiddenServicePort 80 127.0.0.1:80

HiddenServiceDir /var/lib/tor/hidden_service02/
HiddenServicePort 80 127.0.0.1:80

and configure as follows on 000-default.conf on apache (etc/apache2/sites-available/):

 <VirtualHost 127.0.0.1:80>

    ServerName MyAdressOnionV3.onion

    ServerAdmin webmaster @ localhost
    DocumentRoot /var/www/

    Header always append X-Frame-Options SAMEORIGIN
    Header set X-XSS-Protection "1; mode = block"
    Header always set Strict-Transport-Security "max-age = 2592000; includeSubDomains; preload;"
    </ VirtualHost>

    **<VirtualHost 127.0.0.1:80>

    ServerName MyOldAdressOnionV3.onion

    ServerAdmin webmaster @ localhost
    DocumentRoot /var/www2/

    Header always append X-Frame-Options SAMEORIGIN
    Header set X-XSS-Protection "1; mode = block"
    Header always set Strict-Transport-Security "max-age = 2592000; includeSubDomains; preload;"
    </ VirtualHost>**

I specify that in "hidden_service02" I have the "hostname" files secret_key "and" public key " that I transferred from my old server

When I open the file "secret_key" and "public key" with notepad, I have no RSA key but it starts with "== ed25519v1-public: ......" and other bizarre character do not know if it's normal

Most no domain works What do I do wrong?

Help me please, thank you in advance

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.