3

I have the latest Tor browser bundle installed on OSX 10.8.5. It connects and I see the 'Congratulations!' page but am unable to browse to any sites e.g. startpage.com or run a search - I just see 'connecting' in the tab title . This was working for me last week so am not sure what has changed.

  • Is your normal internet connection working without Tor? Have you tried to use a new identity or to restart Tor Browser? – Jens Kubieziel Apr 27 '14 at 14:34
  • 1
    Yes and have tried both restarting & reinstalling – codecowboy Apr 27 '14 at 16:45
  • I have the same problem on 10.9.1, update to 3.5.4 bundle and stopped working. Connection to the tor network seems to go well but the browser cannot access both regular an .onion domains. – user1675 Apr 27 '14 at 23:08
  • @jep good to hear I'm not the only one. Please post back here if you resolve it. – codecowboy Apr 28 '14 at 8:23
3

This was caused by this issue with Sophos Anti Virus:

#10521 TBB 3.5 for OS X v. 10.9.1 does not connect to any websites

Upon further testing of this issue, it was discovered that Sophos anti-virus is blocking Tor from making connections.

To use TBB 3.5 in a Mac environment, users running Sophos must disable the two options found under Preferences > Web Protection:

  • "Block access to malicious websites..."
  • "Block malicious downloads from websites..."

Users are reporting that previous versions of the TBB worked concurrently with Sophos.

0

Also be careful if you use DNSCrypt: if you do, change dns from DNSCrypt dns proxy127.0.0.54 to any other DNS server you like as, for example, google (8.8.8.8).

I'm on Osx 10.9.3 and since 10.9.0, I realized that often TBB does not work correctly if DNSCrypt is using it own dns proxy.

You can change configuration also directly from DNSCrypt manager panel in System Preferences.

Flag "Enable DNSCrypt" UNFLAG "Alway use OpenDNS"

This permits you to change the DNS server in the Network-> Advanced-> DNS panel in System Preferences.

Of course you can set the DNS server to openDNS if you wish, but unflaging Alway use OpenDNS the important result is that Advanced tab in Network panel is not more forced to use the DNSCrypt DNS proxy (127.0.0.54)

Hope this can help you.

A.G.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.