3

When I open the Tor Browser Bundle I get an error message from Firefox: "Cannot load XPCOM". How can I start the Tor Browser?

  • have you tried reinstalling the tor browser bundle? – puser Apr 25 '14 at 16:25
2

Answer #1: This error message is discussed as #10789 in Tor's trac. Users who report this message have a Webroot product installed. This software blocks several DLL files. After Webroot was uninstalled Tor Browser worked without any problems on those users.

In a comment to the release notes of TBB 3.5.2 another one notes:

If you have webroot antivirus, go to ---|--- IDENTITY PROTECTION ---|--- Application Protection ---|--- and allow gkmedias.dll in C:\users\..\tor browser\browser

Under Application Protection, allow anything that Webroot has listed that is from your Tor Browser Folder.

Answer #2: this same issue came up much more recently, with users running "Windows 10 preview build 14251". See Tor ticket 18171 for details. Moving to a newer version of Windows 10 preview will resolve the problem.

  • Doesn't work for me. It does for awhile then Webroot blocks Tor again. They just hate Tor. I'm ditching Webroot when it expires. I'm tired of allowing everything in the Tor bundle. Then when Tor updates it starts all over again. Also, you can't sort or search Application Protection and when you "allow," which you can only do one file at a time, it then just puts that randomly and relists, making it Really Hard to do an entire Tor folder, file by file by file. Their application protection listing is just horrible. – cybervigilante Jul 24 '14 at 2:52
  • I do not have webroot. Everything was working fine until I had the last windows update. – Guest Jan 13 '18 at 20:28
1

I had this same problem. At first I thought I had to delete Chrome or Firefox, but that was not the problem. The problem was that my webroot security software was preventing tor from opening.

YOU DON'T HAVE TO DELETE YOUR WEBROOT SECURITY. Here is what you do:

  1. Open Webroot

  2. Click on "Identity Protection"

  3. Click on "Application Protection"

  4. Find the file that has the word "tor" in it. For example mine says, "firefox.exe in c:\users\desktop\torbrowser\browser"

  5. Then look to the right and you will see the following options: protect, allow, deny.

  6. Select "allow"

This will fix this problem. Hope this helps you.

Not the answer you're looking for? Browse other questions tagged or ask your own question.