I have a windows 10 Laptop. I tried to download TOR, and when I downloaded the first file, the one on their website, it had that message. I downloaded it successfully, but when i tried to open it, it told me my PC couldnt take the version. For direct quote see the title.

  • huh what laptop you're using is it arm64 architecture?
    – user32272
    Apr 22, 2021 at 6:20
  • I think this should be a comment. Please remove your answer and put it as a comment to the question.
    – Swangie
    Apr 22, 2021 at 11:42
  • Where did you download Tor, what is your windows version and is it 64 bit or 32 bit? Please provide more information or your issue cannot be solved properly.
    – Swangie
    Apr 22, 2021 at 11:43

1 Answer 1


There is a lot of critical information missing: where you got TOR from, Windows version, 64bit or 32bit, logs, anything else. There are many reasons why an executable file may refuse to run. Some of the reasons may be:

  • Bad Architecture (running 64bit version of TOR on a 32bit version of Windows). This is the most likely cause. Please give us your version of Windows and TOR.
  • Sideload apps is configured in Windows Settings to only run apps from the Microsoft Store. (Open Settings then go Update & Security and then For Developers. There, underneath Use Developer Features, lie 3 radio buttons. Ensure that Sideload Apps option is selected)
  • Bad Registry (open an administrator Command Prompt and type the command sfc /scannow)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .