1

I am using Tor Browser on Lunx Mint 19.1. In the beginning it worked seamlessly, but in the last few days it took several minutes to start up.

To understand it better I started 'torbrowser-launcher' from the console. Apparently startup is so slow, because it takes several minutes to refresh the local GPG keyring. The same behaviour occurs when I call 'gpg --refresh-keys'. Other keys are refrshed quickly, but refreshing the Tor Browser Developers' key takes a very long time.

Is there anything I can do about this?

  • I have the same issue as OP. My tor relay connection seems fine, I have tor connectivity that works fine with multiple applications, none of them start slowly or do anything unexpected. they start up and are connected immediately to the tor network... Running lubuntu 18.04. When first installed torbrowser-launcher everything worked as expected. Somewhere along the way a couple months ago or so this started to happen. Like op all I can tell is the issue is something between torbrowser and refreshing the gpg-keyring. Something is wrong. It shouldn't take 10 minutes to open torbrowser.. I wish mo – helloooooo Jul 29 at 14:42
  • I know it does not help, but I wished to topic would get more attention. I have the same problem (also on Ubuntu 18.04). My worst fear these days is to accidentally close my browser since it takes so long to restart .... – Franz Aug 1 at 19:50
  • I suspect the issue is caused by the attack on the keyserver network: gist.github.com/rjhansen/67ab921ffb4084c865b3618d6955275f If I kill the gpg process that begins when I run the tor launcher, the browser starts right up. This is obviously bad for security reasons if I'm worried that someone may have sabotaged by local copy of tor, but it does demonstrate that the issue lies with the gpg key. – Kyle Ferendo Oct 7 at 14:59
1

Welcome to StackExchange! Based on the question from my understanding the application is slow because the gpg keyring is not connecting to a tor relay if I understand correctly.

There are multiple factors that can cause the keyring to not be responsive though most of them may be out of your control.

To start off with the more basic problems, are you sure that nothing is blocking your connection to the torprojects entrance node? such as a firewall rule, VPN, DNS filter, etc.

Also, you can check the status of all the tor relay nodes with https://torstatus.blutmagie.de/, you may be entering through a bad node if so reset your connection.

If it is none of the above it may be a problem associated with where the key is trying to connect, You can manually install the tor browsers repository straight from the website, here's a quick script that can do that automatically:

echo "deb https://deb.torproject.org/torproject.org stretch main" | sudo tee -a /etc/apt/sources.list
echo "deb-src https://deb.torproject.org/torproject.org stretch main" | sudo tee -a /etc/apt/sources.list
sudo add-apt-repository ppa:webupd8team/tor-browser -y 
sudo apt-get install tor-browser -y 
apt install torsocks
apt install tor-geoipdb
deb https://deb.torproject.org/torproject.org $V main
gpg --keyserver keys.gnupg.net --recv 886DDD89
gpg --export A3C4F0F979CAA22CDBA8F512EE8CBC9E886DDD89 | sudo apt-key add -
apt-get install deb.torproject.org-keyring
apt install tor -y

after this has been executed it should work back to normal, I hope this may help you.

  • Thank you for the quick and detailed answer. The connection works fine and the status of the relay nodes in the link above appears nicely after a few seconds. As I said the only thing that's really slow is the startup. Once the Tor Browser is running it runs nice and smoothly. The repository you mention looks like a Debian Stretch repository, it is also supposed to used for its derivatives? (Actually I might have used it in the first hand for the installation, but can't remember so I just want to make sure) – kXuJfG5B Jul 6 at 13:03

protected by Community Aug 7 at 14:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.