0

Tor has been giving a consistent parse error for a few months now. I genuinely could not find any weird characters in my /etc/tor/torrc file, I got the aforementioned parse error using the config file that comes out of the box, got it with an empty file and finally tried removing the file altogether. After removing the file I still got the same error (included below). If anybody has any idea what might be going wrong then your input is appreciated.

# tor
May 14 18:17:48.200 [notice] Tor 0.3.5.8 running on Linux with Libevent 2.1.8-stable, OpenSSL 1.0.2r, Zlib 1.2.11, Liblzma N/A, and Libzstd N/A.
May 14 18:17:48.200 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
May 14 18:17:48.200 [notice] Configuration file "/etc/tor/torrc" not present, using reasonable defaults.
May 14 18:17:48.203 [notice] Opening Socks listener on 127.0.0.1:9050
May 14 18:17:48.203 [notice] Opened Socks listener on 127.0.0.1:9050
May 14 18:17:48.000 [warn] Error while parsing configuration: Excess data after quoted string
May 14 18:17:48.000 [err] set_options(): Bug: Acting on config options left us in a broken state. Dying. (on Tor 0.3.5.8 )
May 14 18:17:48.000 [err] Reading config failed--see warnings above.
  • Check if your torrc file is really present. If not check torrc file permissions. – sudo May 16 at 3:32
  • I get the same "Excess data after quoted string" error when the torrc file exists and I know that Tor is reading it when it is there because Tor is acting on the logging options that I set for it without throwing out complaints about not being able to read the file. The reason that this is confusing me so much is because I get a parsing error regardless of whether Tor is reading a config file or not. The error message that I posted was what I got when I specifically removed my torrc file to see if it would clear the error. The error persists whether or not the torrc exists – Chib May 17 at 0:27
  • You can do a fresh start, reinstall your distro then setup Tor. Otherwise remove Tor related directories then reinstall Tor. I would highly recommend the former. – sudo May 17 at 3:04
  • A full on reinstall sounds pretty dramatic (and the kernel that I'm running was compiled a few days ago). Any particular reason why you'd err on that side? – Chib May 17 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.