0

Every time I try to run tor as non root I get the error

Directory /var/lib/tor/hidden_service/ cannot be read: Permission denied

So then when I run it as root it says

You are running Tor as root. You don't need to, and you probably shouldn't.

I'm trying to get a tor website running on my pi. What should I do?

Edit: I fixed it. Apparently the /var/lib/tor folder is owned by a used "debian-tor". Run tor with sudo -u debian-tor tor to get it to work

New contributor
r.rodriguez is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 1
    How did you install tor, and what are the permissions on /var/lib/tor and /var/lib/tor/hidden_service? What’s the value of HiddenServiceDir in your torrc file? You need to make sure that the user running tor has permission to access this directory. – Steve yesterday
  • This led me to the solution. I just made the edit. Thanks! – r.rodriguez 11 hours ago

Your Answer

r.rodriguez is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.