I’ve tried running Tor with the following in a config file:

SocksPort 9050 SessionGroup=1

I get [warn] Invalid SocksPort option ‘“SessionGroup=1”’ and Tor fails to start.


Tor's manpage writes:

SocksPort [address:]port|unix:path|auto [flags] [isolation flags]

So this means the correct name of the option is SocksPort and the correct version of the line above is:

SocksPort 9050 SessionGroup=1
  • My bad, there was a typo in the question. My config is as what you wrote when I got the error. – nibs Mar 5 '19 at 6:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.