3

This seems to started after I specified an IPv6 address for my ORPort. Everything server side indicates my DirPort is reachable, but Tor Metrics (not tor on my server) says it is unreachable (although I am reachable by IPv6 and IPv4 on my ORPort, according to the site). At the same time I set my IPv6, I did also limit my AccountingMax to 20TB out, renewing every month

Tor logs indicate that testing proved my DirPort reachable. I am running Tor 0.3.5.7 on Ubuntu 18.04.2 server x86_64.

EDIT: I upgraded to Ubuntu 18.10 and Tor 0.3.5.8, and the issue persists

SOLVED For some reason, if I don't set AuthoritativeDirectory to 1, along with bridge authority, it doesn't seem to publish me as a directory relay. Originally, I thought it might be a ports issue, but I run an Apache webserver off of ports 80&443 and have no issue

Now my question is: why is this happening?

Everything indicated I set it up correctly. Is there any way to see if my dirport is being used?

3
  • Have you tried connecting to the DirPort from an outside connection? Are you sure there is no ISP firewall blocking it? For example home ISPs often block port 80, which is a commonly used DirPort.
    – Steve
    Feb 15 '19 at 23:58
  • I can access the Tor site on it, yes. I host my VPS with Hetzner, they don't block ports that I'm aware of
    – unixandria
    Feb 16 '19 at 0:13
  • Can you publish your torrc? Seems like you configured something weird here, you should never use AuthoritativeDirectory unless you're one of the 10 or so approved authorities. metrics.torproject.org/rs.html#search/flag:authority Jul 26 at 12:11
1

As per changelog, Tor, starting with 0.4.6, no longer publishes any DirPort:

Removed features (relay):

  • Because DirPorts are only used on authorities, relays no longer advertise them. Similarly, self-testing for DirPorts has been disabled, since an unreachable DirPort is no reason for a relay not to advertise itself. (Configuring a DirPort will still work, for now.) Closes ticket 40282.

DirPort is deprecated and should no longer be configured.

1
  • Although this is an old question and I actually no longer run a relay it does explain why it didn't work.
    – unixandria
    Jul 27 at 13:51
0

Now my question is: why was this happening? Does Tor not allow a DirPort of 80? I can verify it was unblocked, and nothing should have been using it (nor was it when I checked)

I host my VPS with Hetzner, they don't block ports that I'm aware of

It seems as your VPS doesn't allow some customers to open port 80. Thats the only explanation I could think of. It happend to me when I tried to host a website on a VPS. After some chatting with customer support, they said that they block certain ports on a low price VPS plans.

3
  • No, it's not that. Apache works with port 80
    – unixandria
    Feb 21 '19 at 14:21
  • Then its really strange, can you link any logs or anything that could help identifing why changing the port helped? Feb 21 '19 at 14:23
  • 1
    see my new edited question
    – unixandria
    Feb 21 '19 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.