0

I have successfully hosted my first .onion site on my Raspberry Pi by following this tutorial. For some reason I needed to stop running this site for a while. So I used this command sudo /etc/init.d/tor stop to temporarily close this site and then I used sudo /etc/init.d/tor startto start the website again. But it's not working and I'm not able to visit my .onion site again. I have tried restarting my Raspberry Pi and start again but still not working. I have also tried restarting lighttpd but still not working. I have also tried sudo /etc/init.d/tor restart but still not working.

And sudo /etc/init.d/tor status shows my hidden service is active. But I'm not able to visit it anymore.

● tor.service - Anonymizing overlay network for TCP (multi-instance-master)
   Loaded: loaded (/lib/systemd/system/tor.service; enabled; vendor preset: enabled)
   Active: active (exited) since Tue 2018-11-06 00:05:42 UTC; 14min ago
  Process: 328 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 328 (code=exited, status=0/SUCCESS)
      CPU: 0
   CGroup: /system.slice/tor.service

Nov 06 00:05:42 raspberrypi systemd[1]: Starting Anonymizing ove…..Nov 06 00:05:42 raspberrypi systemd[1]: Started Anonymizing over…).Hint: Some lines were ellipsized, use -l to show in full.
  • Did you checked your torrc? If it is OK, may be your tor service uses another torrc file. For this, start tor instance with -c for giving the right torrc and check if your hidden service is available? – Mir Saman May 3 at 6:54
0

Did you check your hostname file to ensure the location did not change? If the service is active, it does not sound like it is failing. That's why I'm suggesting that maybe there's an issue with how you're accessing it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.