I have Kali GNU/Linux Rolling (v. 2018.2) installed on the Raspberry Pi 3 B+. I downloaded and installed Tor Browser (32-Bit) and when I try to run "./start-tor-browser" nothing happen: enter image description here I also tried to run "./start-tor-browser.desktop" and it returns "Launching './Browser/start-tor-browser --detach'..." enter image description here - I tried to do that on both root and user account;
- I changed the owner to be the root for the whole directory;
- I edited the file Browser/tart-tor-browser and changed the if condition from if ["id -u" -eq 0] to "-eq 1";
- I also tried to comment the whole if condition;
- I moved the "tor-browser_en-US" folder to /etc;
- I executed command "chown -R root *" in "tor-browser_en-US";
I have read all topics with a similar problem and checked youtube vidoes but I didn't find any solution.


You're trying to run Tor Browser as root, it will not run as root because it's an incredibly bad idea.

You'll want to install/extract and run it as a user other than root.

Not the answer you're looking for? Browse other questions tagged or ask your own question.