0

I'm trying to run different instances of tor simultaneously. One without exit node set and one with set exit note. To do so, I have to change the port and change the DataDirectory as well (Correct?). But running tor -f /etc/tor/torrcGB cause this log:

May 28 16:15:16.473 [notice] Tor 0.3.3.6 (git-7dd0813e783ae16e) running on Linux with Libevent 2.1.8-stable, OpenSSL 1.1.0h, Zlib 1.2.11, Liblzma 5.2.4, and Libzstd N/A.
May 28 16:15:16.473 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
May 28 16:15:16.473 [notice] Read configuration file "/etc/tor/torrcGB".
May 28 16:15:16.475 [warn] ControlPort is open, but no authentication method has been configured.  This means that any program on your computer can reconfigure your Tor.  That's bad!  You should upgrade your Tor controller as soon as possible.
May 28 16:15:16.475 [notice] Scheduler type KIST has been enabled.
May 28 16:15:16.475 [notice] Opening Socks listener on 127.0.0.1:9060
May 28 16:15:16.475 [notice] Opening Control listener on 127.0.0.1:9061
May 28 16:15:16.475 [warn] Error creating directory /var/lib/torGB: Permission denied
May 28 16:15:16.475 [warn] Failed to parse/validate config: Couldn't create private data directory "/var/lib/torGB"
May 28 16:15:16.475 [err] Reading config failed--see warnings above.

here is my /etc/tor/torrcGB:

Log notice syslog

# To be able have different tor
SocksPort 9060
ControlPort 9061
DataDirectory /var/lib/torGB

# Set for GB exit node
ExitNodes {uk},{gb},{io},{vg}
StrictNodes 1

UseBridges 1
ClientTransportPlugin obfs4 exec /usr/bin/obfs4proxy managed


bridge obfs4 35.162.230.20:9443 CA8D14F8C289B13AD9D1D22262744EBE4761DD15 cert=H39+NPm6vxyimJFDbbhuhq8AFaGZ2Uw1OOMPAX1QiR5+M5YvLgcRdEOpyfDIwqiLX1KdRw iat-mode=0

I tried creating /var/lib/torGB/ directory myself, set the owner to tor and even copy the /var/lib/tor/ and rename it (and change the owner)...all these efforts didn't work.

0

There are two possibilities I know of which may cause this problem:

  1. Tor is running as non-root user and permissions on /var/lib do not allow that user to create directory. As you tried to fix it by hand this is probably not that case.
  2. You have selinux (or similar technology) enabled and it gets in a way. Try to disable it (setenforce 0) and see if this helps. If so - you may need to manually adjust selinux context on the files and directories to let tor to run or just disable it altogether (not recommended).
  • The first item might be the case since my /var/lib/tor folder and all contents belong to tor user (a built-in user I think). Regarding the second, I don't have selinux. – SdidS May 30 '18 at 6:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.