0

I get the warning below when starting running a bridge.

Should I change the torrc file, or do something else, to deal with this problem, or should I ignore the message?

Apr 14 06:16:02.385 [warn] OpenSSL version from headers does not match the version we're running with. If you get weird crashes, that might be why. (Compiled with 1000207f: OpenSSL 1.0.2g-fips 1 Mar 2016; running with 1000207f: OpenSSL 1.0.2g 1 Mar 2016).

Apr 14 06:16:02.430 [notice] Tor 0.3.2.10 (git-0edaa32732ec8930) running on Linux with Libevent 2.0.21-stable, OpenSSL 1.0.2g, Zlib 1.2.8, Liblzma 5.1.0alpha, and Libzstd N/A.

0

It seems that you compiled the tor yourself, there seems to be some compatibility issues in the libraries.

Try to instal pre buit tor from a repository.

For debian based:

 sudo apt install tor

Also try to update all your libs

sudo apt update
sudo apt upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.