5

What i have done:

  1. Downloaded the tor expert bundle zip file
  2. extracted the zip file toC:\tor\
  3. Add the C:\tor\Tor to the Path system environment variable
  4. Added C:\tor\Tor\tor.exe to the LOCAL SERVICE group with the Full Control privileges
  5. Add C:\tor\ directroy to the SERVICE group with the Full Control privileges
  6. Created the torrc file in C:\tor\Data\Tor\torrc
  7. Created the C:\tor\Data\DataDir directory
  8. Used tor --service install -options -f C:\tor\Data\Tor\torrc to make tor service

The contents of the torrc file

DataDirectory C:\tor\Data\DatadDir
ControlPort 9051
HashedControlPassword 16:09...

What i get

PS C:\Windows\system32> tor --service install -options -f C:\tor\Data\Tor\torrc
Running on a Post-Win2K OS, so we'll assume that the LocalService account exists.
Done with CreateService.
Service installed successfully
Service failed to start : An exception occurred in the service when handling the control request.

This is what i get when trying to manually start the service.

error_1064

I tried the tor-win32 zip file from https://dist.torproject.org/torbrowser/7.5.1/ and the same error displayed again. Anyway when i run the command tor --service install the service is installed and started successfully. So i guess there is a problem with the torrc file.

6
  • 2
    Did you resolve the issue?
    – Kamil
    Jul 9, 2018 at 19:49
  • post your full torrc file, please - without passwords, cookies e.t.c... It's impossible to guess it all by the data you provided
    – Alexey Vesnin
    Sep 17, 2021 at 20:01
  • 1
    @AlexeyVesnin Hi, The question is asked 3 and a half years ago:). I'm a Linux user now and don't know even if the question is still relevant. Now that i'm here I recommend windows users to use NSSM to run an executable as a windows service
    – pouya
    Sep 17, 2021 at 20:31
  • 1
    Glad to hear that :) Actually, tor runs very well as a Windows service, so there should be no problem for the task you've tried to perform: windows 7,8 and 10 are running Tor service just fine out of the box
    – Alexey Vesnin
    Sep 18, 2021 at 6:55
  • @pouya It's now over one year later and I can confirm this is still relevant. Getting the same issue, don't have a solution yet..
    – C4d
    Dec 12, 2022 at 18:36

1 Answer 1

2

Verify that none of the paths provided are relative or contain environment variables, because neither is handled properly. Also, I also had problems with paths because I used UNIX-style path separators on my Windows machine. --verify-config yelled at me what the paths provided were relative when they were not – because they explicitly started with the drive letter and root directory specification. I had to fix all of the above issues before the Tor service could run properly.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .