0

I unpacked Tor Expert Bundle to C:\ and run tor --service install -options -f <path_to_my_torrc>, the service succesfully installs and runs. Tor Network works fine.

But when I tried to install Tor Expert Bundle from my user directory (win8, something like C:\User\<Cyrillic user name>\Desktop\Tor), the service installs but can't start with error "access denied". I added rules:

icacls %cd% /grant "LOCAL SERVICE":(OI)(CI)RX
icacls %cd%\Data /grant "LOCAL SERVICE":(OI)(CI)M

Then the service installs and starts correctly, but tor network doesn't work.

My torrc file:

#DataDirectory C:\Users\Андрей\Desktop\Tor Expert Bundle\Data
GeoIPFile C:\Users\Андрей\Desktop\Tor Expert Bundle\Data\geoip
GeoIPv6File C:\Users\Андрей\Desktop\Tor Expert Bundle\Data\geoip6

ExcludeExitNodes {ru}, {ua}, {by}, {kz}
ExitNodes {pl}

I tried to add quotes to file paths, but i got error 1064. I tried to add DataDirectory parameter, but i also got error 1064.

When I run Tor Browser Bundle from the same directory, tor succesfully starts. How to place tor expert bundle in my user directory (with cyrillic symbols in the file path)?

0

The problem occured by cyrillic symbols. Quick solution is using in torrc for TEB paths, generated by TBB for their torrc. True way: encode your non-latin symbols to escaped octal CP-1251 numbers, escaping all other slashes in path and path quotation. For example: DataDirectory C:\Users\Андрей\Desktop\Tor Expert Bundle\Data -> DataDirectory "C:\\Users\\\300\355\344\360\345\351\\Desktop\\Tor Expert Bundle\\Data" This variant works, all other tested (without quotes, double escaping, etc) don't.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.