0

I was trying to verify TOR package signature with this command:

gpg --keyserver pool.sks-keyservers.net --recv-keys 0x4E2C6E8793298290

I got this response

gpg: requesting key 0x4E2C6E8793298290 from hkp server pool.sks-keyservers.net
?: invalid HTTP proxy (socks5-hostname://127.0.0.1:9050): unsupported URI
gpgkeys: HTTP fetch error 7: couldn't connect: Success
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0
gpg: keyserver communications error: keyserver unreachable
gpg: keyserver communications error: public key not found
gpg: keyserver receive failed: public key not found

Thankfully I was able to do the actual verification by using another computer (both Ubuntu 16.04LTS).

But someone pointed out that my main system's GnuPG configuration is not default, as it's expecting HTTP proxy. This seemed proven true by moving the same files (package and signature) to another computer with the same OS and giving the same command and it worked instantly.

Does anyone know how to restore my GnuPG configuration to default on my main system? Thanks.

  • What version of gnupg do you have? you might just be able to edit ~/.gnupg/dirmngr.conf and add a line saying use-tor. gnupg.org/documentation/manuals/gnupg/… otherwise, edit ~/.gnupg/gpg.conf and remove the proxy config line and invoke gpg as torsocks gpg – cacahuatl Feb 5 '18 at 4:50
  • That's strange. I did apt-get update & upgrade, but when I enter the version command: $ gpg --version , I get: gpg (GnuPG) 1.4.20 Copyright (C) 2015 Free Software Foundation, Inc. License GPLv3+: GNU GPL version 3 or later <gnu.org/licenses/gpl.html> Isn't there a newer version?? Why did apt-get not update it? – Jerry777 Feb 5 '18 at 13:39
  • Maybe the standard Ubuntu repository, which apt-get uses, isn't updated? Anyway I see GnuPG version 2.2.4 is available and I'm working on that. Thanks. – Jerry777 Feb 5 '18 at 13:44
  • And apparently gpg2 is different from gpg (sigh): I did: gpg2 --help, I got: gpg (GnuPG) 2.1.11 libgcrypt 1.6.5 – Jerry777 Feb 5 '18 at 14:00
0

cacahuatl: I don't know how to 'invoke gpg as torsocks gpg'. But I do know how to delete things. So I backed-up and then deleted gpg.conf and gpg-agent.conf. Now when I issue the exact same command

gpg --keyserver pool.sks-keyservers.net --recv-keys 0x4E2C6E8793298290

I get a much better result:

gpg: requesting key 93298290 from hkp server pool.sks-keyservers.net
gpg: key 93298290: public key "Tor Browser Developers (signing key) " imported gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0 valid: 1 signed: 1 trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1 valid: 1 signed: 0 trust: 0-, 0q, 0n, 0m, 1f, 0u
gpg: next trustdb check due at 2018-07-23
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)

What effect does this change have on my system? Not sure. But I've tested my gpg signature verification functions as well as encryption/decryption and all are functional now (thank God). Thanks for your help.

  • For the benefit of other newbie users here, and because the 2 config files might be useful one day, I restored the files and found that all I needed to do to restore keyserver download function (originally to verify the TOR package) was to open /home/.gnupg/gpg.conf with a text editor, find the line keyserver-options http-proxy=socks5-hostname://127.0.0.1:9050 and put a # in front of it to de-activate it. – Jerry777 Feb 6 '18 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.