6

As the title says, I've been trying to use Tor as a proxy for Postman and I'm getting the following response when I try to make a request to a specific endpoint that does not support HTTPS

This is a SOCKS Proxy, Not An HTTP Proxy

This is a SOCKs proxy, not an HTTP proxy.

It appears you have configured your web browser to use this Tor port as an HTTP proxy.

This is not correct: This port is configured as a SOCKS proxy, not an HTTP proxy. If you need an HTTP proxy tunnel, use the HTTPTunnelPort configuration option in place of, or in addition to, SOCKSPort. Please configure your client accordingly.

See https://www.torproject.org/documentation.html for more information.

But the thing is, when I use the Tor browser, I can visit the same site just fine.

So what is the browser doing different than my "tor.exe" proxy? Are there any ways around this?

  • The question was about how to run tor.exe from Windows, I have to laugh at looking at the responses from the Linux console. If the author of the answer is no longer what is Windows and what is Linux is useless. Run the polipo or old privoxy on the Windows port configuration. – Guest Apr 25 at 2:28
11

Tor provides a SOCKS proxy by default.

Whatever you've configured to use Tor is trying to use it as an HTTP proxy which is a different kind of proxy protocol.

Tor (at least as of 0.3.2.x) can provide an HTTPTunnelPort which provides an HTTP CONNECT proxy interface. If the application is capable of using an HTTP connect proxy (instead of a transparent HTTP proxy) then you should be able to configure Tor by running, for example, tor.exe --HTTPTunnelPort 8118 from the command line, which would give you an HTTP CONNECT proxy on port 8118.

If applications cannot support HTTP CONNECT or SOCKS then they will not be able to use Tor without using Transparent Proxying to force internet connections to use Tor.

  • i was having this problem with gradle in android studio. this solution worked for me – A.easazadeh May 25 at 10:02
  • I was able to config and use tor using HTTPTunnelPort option, but now I can only open https sites, is there any flag/config resolve this problem? – Mehdi Dehghani Jun 13 at 4:35
4

As @cacahuatl said you can use that switch, if you want it to be permanent go to /etc/tor/torrc (This is the path for tor config file in Ubuntu and Debian), open it with your favorite text editor and add HTTPTunnelPort 9080 at the end of the file, reset tor service with this command:

sudo service tor restart

and you're done.

  • Thanks so much, How can i use this proxy in my bash shell? – shgnInc Jan 13 at 5:17
  • Before anything run the below command to see which port being used by tor. sudo netstat -tpln | grep tor , forth column is address and port which tor listening to, mine is 127.0.0.1:9050 . then whenever you want to use it in your script address it like this socks5://127.0.0.1:9050. – Siyavash vaez afshar May 21 at 10:22

protected by Community Apr 25 at 20:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.