0

I am setting up tails with crypto wallets of currencies I use. The problem is that torify does not for some reason work with them. I don't really care that much about anonymity, so I have reset iptables to defaults assuming that should do the trick. But it didn't and it seems DNS lookup is failing in the wallets. Any help?

1

When you "reset" (I assume you mean you flushed/cleared) iptables, you also killed the iptables rule which was redirecting traffic destined to 127.0.0.1:53 to 127.0.0.1:5353. The latter IP/Port is where Tor is actually listening and DNS requests are no longer able to reach the DNS listener and so nothing will resolve anymore.

You will either need to take a more nuanced approach to iptables reconfiguration or change the prefered DNS servers to no longer try to use Tor to resolve traffic.

Note that disabling iptables in such a manner will break many of the assumptions of Tails' security and may expose you to risks in ways that were previously mitigated against.

0

You can run most of the bitcoin based crypto coin wallets in tails linux without modifying iptables at all, if you specify your socks5 proxy to connect to. Here dash wallet as example:

./dash-qt --proxy=127.0.0.1:9050

This should work with most of the typical c++ qt-wallets. In case you want to run a wallet daemon, you could use the same proxy setting, but for wallet-cli connections to it, you would then need to adjust iptables for your wallet rpc port:

sudo iptables -I OUTPUT 3 -d 127.0.0.1 -o lo -p tcp --dport 9998 --syn -m owner --uid-owner amnesia -j ACCEPT

The example above makes port 9998 (dash wallet rpc port) accessible - adjust the port for other wallets accordingly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.