0

First of all I use Tor a lot (as a user) and feel I should contribute to it if I can. To that end, I recently installed tor (from git) and point my firefox proxy settings to SOCKS and 127.0.0.1 9050 and the "check if using Tor" page says congrats.

Now I would like to be an exit relay. Up front, I know almost nothing about networking, the internet, etc. so please provide details if you volunteer help. My /usr/local/etc/tor/torrc file is:

 ControlPort 9051
 CookieAuthentication 1
 ORPort 9001
 Nickname ********
 RelayBandwidthRate 100 KB  # Throttle traffic to 100KB/s (800Kbps)
 RelayBandwidthBurst 200 KB # But allow bursts up to 200KB/s (1600Kbps)
 DirPort 9030 # what port to advertise for directory connections

I've seen some solutions using dnsexit or tor-fw-helper, but this is certainly not in my wheelhouse and those helps do not provide enough details. Can anyone help me to get this running?

I'm on Linux Mint 18.2 and using a wifi router WNDR3800 Netgear (though I'd plug in a LAN cable if it helped). I'm also with MyCharter.

Thanks in advance!

PS: I've waited a while and now the warning seems to have concluded wtih;

Sep 11 17:33:01.000 [warn] Your server (72.174.26.72:8999) has not managed to confirm that its ORPort is reachable. Relays do not publish descriptors until their ORPort and DirPort are reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.
Sep 11 17:33:01.000 [warn] Your server (72.174.26.72:9030) has not managed to confirm that its DirPort is reachable. Relays do not publish descriptors until their ORPort and DirPort are reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.

PPS. Different OS and no solution: Setting up Tor relay and port reachability test failed error message Also, similar reasons for this not helping me Port Reachability Test Failed _ detailed info

1

OK, here is the checklist to solve your problem:

  • first, use ORPort 443 and DirPort 80 - will work a way better.
  • second You need to log in into your router's web interface and see the IP address it receives from your ISP side. If it's a private one - you need to call your ISP to obtain a "public ip" and, if possible, a static one.
  • Last step - set your Tor's machine LAN ip static and forward the ports from your router's web interface to that IP address of LAN machine.

That's it! If you need help - just drop a line, I'll be glad to help you!

  • Thank you for your time to help! So about two hours ago it started working - verified with flags: valid, exit, running, v2dir - and unfortunately I don't know if it was because of eventually starting to work, or by logging into router and port forwarding internal & external port ranges 8999-9030 to the IP used by my machine (can't bind to MAC :( ). So.... I'm a little leary about "if it ain't broke don't fix it". Should I change the ports now? The WAN IP is visible, but it works now anyways... Thanks again! – nate Sep 12 '17 at 17:35
  • it was actually the port forwarding: it checked the reachability, then published the descriptor, and started being evaluated by network so the flags appeared. You don't need port range forwarding - just two TCP ports. And try to use ORPort 443 and DirPort 80 - it will work a way better for you and for network – Alexey Vesnin Sep 12 '17 at 18:53
  • 1
    Sounds great! Thanks again - seems with all the info on tor's site some still need hand-holding :D I'll change the ports – nate Sep 12 '17 at 18:59
  • The ports are irrelevant and won't affect performance in any way. – cacahuatl Sep 13 '17 at 4:43
  • @canonizingironize ports do relevant, because even a high restricted firewall does not cuts https and http. – Alexey Vesnin Sep 13 '17 at 6:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.