3

I'm attempting to setup Tor for use behind a Windows 7 firewall, I have set the firewall to block all outgoing traffic except those with a rule and configured it at first allow traffic for the following exe files.

  • "Tor Browser\Browser\TorBrowser\Tor\tor.exe"
  • "Tor Browser\Browser\firefox.exe"

But that didn't work so I made Inbound/Outbound allow rules for EVERY exe file I could find in the Tor folder and any subfolder and still no go.

Here is the error I get when attempting to connect to Tor.

Screenshot

Here is a copy of the log

8/24/2017 10:40:11 AM.300 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
8/24/2017 10:40:11 AM.300 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
8/24/2017 10:40:11 AM.300 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
8/24/2017 10:40:11 AM.300 [NOTICE] Opening Socks listener on 127.0.0.1:9150 
8/24/2017 10:40:11 AM.700 [NOTICE] Bootstrapped 80%: Connecting to the Tor network 
8/24/2017 10:40:20 AM.700 [WARN] Problem bootstrapping. Stuck at 80%: Connecting to the Tor network. (Permission denied [WSAEACCES ]; RESOURCELIMIT; count 10; recommendation warn; host F4263275CF54A6836EE7BD527B1328836A6F06E1 at 37.187.102.108:443) 
8/24/2017 10:40:22 AM.400 [NOTICE] Closing no-longer-configured Socks listener on 127.0.0.1:9150 
8/24/2017 10:40:22 AM.400 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
8/24/2017 10:40:22 AM.400 [NOTICE] Closing old Socks listener on 127.0.0.1:9150 
8/24/2017 10:40:22 AM.400 [NOTICE] Delaying directory fetches: DisableNetwork is set. 
2
  • Are you running as admin? Aug 25 '17 at 5:29
  • Totally worked!! I tried a bunch of various options before this, but the % issue was the key. Thanks for posting
    – MicIcarus
    Oct 19 at 13:36
0

OLD question BUT it drove me a little crazy until I worked it out.

Windows firewall doesn't like wildcard paths such as '%appdata%\[filename]'.

So move the TOR browser folder (that default installs onto the desktop) on a SSD/HDD top level, i.e. 'C:\tor browser\'.

Finally Make outgoing firewall rules for Tor.exe, Firefox.exe and obfs4proxy.exe (if you are using this bridge); no incoming rules.

This worked for me, I may have allowed too much so if you find a more streamline approach I'll check back to see if anyone posted.

IF YOU WORK THINGS OUT: POST THEM. Even to old comments :)

0

Well, there's a great tutorial I can not add a point to - see it by this link https://winaero.com/open-port-windows-firewall-windows-10/ and for windows 7 or 8 you just need to open the firewall rules editor, it looks the same. What you need to do is two things:

  1. Enable tor.exe binary to make an outbound connections, make sure that it's in a root folder with no spaces and english-only letters! C:\Tor is the right choice
  2. Open the inbound connections for TCP traffic to your ORPort - it will improve your connectivity greatly, most of tutorials do miss this important step.

Not the answer you're looking for? Browse other questions tagged or ask your own question.