0

Few days ago on Android 7.1.2 I have installed Orbot and Orfox from Google Play. Few days back I started Orbot and pressed Start button. Connection was successfully established and Browser button was enabled and I could click on it and Orfox started successfully (check.torproject.org display Congratulations message) and web sites can be normally displayed in Orfox. Then I clicked Stop button in Orbot and clicked on left menu button and selected Bridges and selected "Tunnel through Azure" and pressed the Start button. It took little bit longer, but Browser button was enabled again and I could click on it and Orfox was started successfully. So bridges working fine.

But yesterday and today I can start Orbot without bridges, but when I click on left menu and select Bridges | Tunnel through Azure and connection in Orbot is not completed successfully. I have tried many times (also rebooted Android, yes I know old Windows habit).

Today I did:

  1. Right menu and clicked on Settings.
  2. Scroll down and in Debug section checked the "Debug log" check box.
  3. From menu button I clicked Exit to shutdown Orbot and to clear logs.
  4. Started Orbot.
  5. Left menu Clicked on Bridges | Tunnel through Azure.
  6. Press Start button.

It is interesting Browser button gets enabled, but when clicked on it Orfox starts but check.torproject.org does not load at all, so it looks like connection to Tor network is not established yet.

Bellow is log file. I have looked through the log and replaced anything suspicious with many XXX, to remove potentially sensitive information.

Set background service to FOREGROUND
Orbot is starting…
Orbot is starting…
updating settings in Tor service
updating torrc custom configuration...
torrc.custom=ControlPortWriteToFile /data/data/org.torproject.android/app_bin/control.txt
SOCKSPort 9050
SafeSocks 0
TestSocks 0
WarnUnsafeSocks 1
TransPort 9040
DNSPort 5400
VirtualAddrNetwork 10.192.0.0/10
AutomapHostsOnResolve 1
DisableNetwork 0
Log debug syslog
Log info syslog
SafeLogging 0
UseBridges 1
ClientTransportPlugin meek_lite exec /data/data/org.torproject.android/app_bin/obfs4proxy
Bridge meek_lite 0.0.2.0:1 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX url=https://XXXXXXXXXXXXXX.cloudfront.net/ front=XX.awsstatic.com
Bridge meek_lite 0.0.2.0:2 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX url=https://meek.azureedge.net/ front=ajax.aspnetcdn.com
GeoIPFile /data/data/org.torproject.android/app_bin/geoip
GeoIPv6File /data/data/org.torproject.android/app_bin/geoip6
StrictNodes 0


success.
Orbot is starting…
/data/data/org.torproject.android/app_bin/tor DataDirectory /data/data/org.torproject.android/app_data --defaults-torrc /data/data/org.torproject.android/app_bin/torrc -f /data/data/org.torproject.android/app_bin/torrc.custom
Waiting for control port...
Reading control port config file: /data/data/org.torproject.android/app_bin/control.txt
Connecting to control port: 48691
SUCCESS connected to Tor control port.
SUCCESS - authenticated to control port.
Starting Tor client… complete.
adding control port event handler
SUCCESS added control port event handler
Tor started; process id=12971
Starting polipo process
Polipo is running on port:8118
Polipo is running
Circuit (1) LAUNCHED:
NOTICE: Bootstrapped 5%: Connecting to directory server
orConnStatus ($XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX): LAUNCHED
Circuit (2) LAUNCHED:
orConnStatus (cymrubridge02): LAUNCHED
NOTICE: Bootstrapped 10%: Finishing handshake with directory server
NOTICE: Bootstrapped 15%: Establishing an encrypted directory connection
orConnStatus (cymrubridge02): CONNECTED
Circuit (2) EXTENDED: cymrubridge02
NOTICE: Bootstrapped 20%: Asking for networkstatus consensus
Circuit (2) BUILT: cymrubridge02
Error getting node details from onionoo: timeout

Any idea what is wrong?

I know I can use Orbot without bridges. But currently I am at home when there is no network restrictions (most probably not) by ISP, but when I will go to work I am 100% sure company is blocking TOR network (I know this because using Tor on Windows the only way to get to the Tor network is by using bridges).

I would really like to establish Orbot connection using bridges.

P.S. I have tried Amazon and Obfs4 bridges, but with still unsuccessful.

  • What happens if you try to visit ajax.aspnetcdn.com in a browser? – cacahuatl Aug 4 '17 at 19:25
  • If using Amazon bridge Orbot does not starts successfully, so check.torproject.org or any other site like ajax.aspnetcdn.com does not display anything. Actually loading of web page freezes. But if I do NOT use bridges both sites working just fine. Is there something special about thix ajax.aspnet.cdn.com web site? It is interesting to me Orbot without bridges working fine and with bridges not. If there would be censoring I would expect vice versa. – folow Aug 7 '17 at 5:31
0

I experienced the same situation on my Android phone. Orbot couldn't get connected by turning on Bridges, but could get connected without Bridges. However, the overall success rate getting orbot connected is less than 10%. What amazing is, I could always get connected with Tor Browser on my PC or Mac within 30 seconds, buy using Meek bridges.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.